X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop the Mozilla Start page tab from always popping up?

Posted

Every time I return to my home page another Mozilla Start Page tab pops up. I can get multiple such tabs. How do I stop them from appearing? Nothing I have tried works, and that little grid one so-called suggestion doesn't work because the grid rarely appears.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • McAfee MSS+ NPAPI Plugin
  • 5.1.20125.0
  • Motive Plugin for Mozilla Browsers
  • Motive Management Plug-in for Mozilla Browsers
  • Garmin Communicator Plug-In 4.0.4.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Firefox lets you set multiple home tabs. This is done by placing each URL in your home page setting separated by | characters. Can you check for that? This article describes it in more detail: How to set the home page.

mpeaster123 0 solutions 2 answers

jscher2000: I have tried numerous times to prevent Firefox from opening the Firefox Start page in addition to my preferred home page. It has never worked. I am running FF 21.0 on a Win 7 platform. I have auto-update turned on. These are the steps I followed:

1. Closed the Firefox Start page tab that I do not want to open. 2. Selected Tools > Options > General. 3. Chose "Show my homepage" from the drop-down. 4. Manually entered the URL of the home page I do want (just to be sure Firefox couldn't misinterpret my request). 5. Clicked OK. 6. Exited Firefox. 7. Restarted Firefox, and I still got the Firefox start page in a separate tab in addition to the home page I explicitly set.

What's wrong?

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Hi mpeaster123, is it the same page you get if you type about:home in the address bar and press Enter? Or is the page that comes up after an update saying you have the latest version and would you like the Android version as well?

After making the settings change, if you press Ctrl+n to open a new window, does it have just the home page you want?

A customization file named user.js can override your preference changes. You can check for such a file as described in this article: How to fix preferences that won't save.

If that's not it...

Do you notice any difference if instead of using a shortcut, you start Firefox from the Start menu search box by typing firefox.exe and pressing the Enter key? If so, the command line of the shortcut might need a bit of cleanup.

Could you try Firefox's Safe Mode? After exiting Firefox, hold the Shift key down when starting Firefox. In the dialog that comes up, click "Start in Safe Mode" (not Reset). If you only get your one home page here, it could be because extensions are disabled. After you restart normally, you can review, check Options, disable, or remove extension on this tab:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can check for problems with preferences and rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value.

bobs999 0 solutions 1 answers

Helpful Reply

Don't know if this will help but I had exactly the same problem. I had 'Google' set as my home page and kept getting the annoying Firefox start-up page load too, each time I launched the browser. Then I noticed that something had stuck /about home" after my homepage url [under tools / options / general tab - 'Home Page']. So, in other words, instead of my homepage showing as "http://www.google.co.uk/" it said "http://www.google.co.uk/abouthome". Knocking off the "abouthome" bit seems to have cured it. (opens with Google only now). So perhaps check nothing has been unwittingly added to your homepage url ?

Vinay B S 0 solutions 2 answers

Hi,

Please go through this page once for the solution.

https://support.mozilla.org/en-US/que.../959413?esab=a&as=s&r=0&page=2