X
Tap here to go to the mobile version of the site.

Support Forum

Why is FF accessing the Internet almost continuously?

Posted

How can I stop FF accessing the network long after a page has been downloaded? I tried toggling network.dns.disablePrefetch boolean false to true, and network.prefetch-next boolean true to false using about:config, but it did not help. I am concerned that there might be some malware running, though I have a fully updated Windows 7 Professional x64 system with Microsoft Security Essentials. I also ran Malwarebytes Anti-Malware, which found no problems. I am basing my observation on my Network Activity Indicator icon in the Taskbar.

How can I stop FF accessing the network long after a page has been downloaded? I tried toggling network.dns.disablePrefetch boolean false to true, and network.prefetch-next boolean true to false using about:config, but it did not help. I am concerned that there might be some malware running, though I have a fully updated Windows 7 Professional x64 system with Microsoft Security Essentials. I also ran Malwarebytes Anti-Malware, which found no problems. I am basing my observation on my Network Activity Indicator icon in the Taskbar.

Chosen solution

Thanks Philipp, that's extremely helpful information. I changed the Setting in the activity indicator to Network traffic only, and the symptom has dramatically decreased. This completely alleviates my original concern. Problem solved.

Renny

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Foxit Reader Plug-In For Firefox and Netscape
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Google Update
  • 5.1.20125.0
  • NPWLPG
  • wpidetector
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Java Console 6.0.33 ({CAFEEFAC-0016-0000-0033-ABCDEFFEDCBA})
  • Java Console 6.0.35 ({CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA})
  • RoboForm Toolbar for Firefox 7.8.8.5 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • SmoothWheel (mozdev.org) 0.45.6.20100202.1 ({5F590AA2-1221-4113-A6F4-A4BB62414FAC})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Google Toolbar for Firefox 7.1.20110512W ({3112ca9c-de6d-4884-a869-9855de68056c}) (Inactive)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 6150SE nForce 430
  • adapterDescription2:
  • adapterDeviceID: 0x03d0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvd3dum
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'257.21']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 4-1-2010
  • driverDate2:
  • driverVersion: 8.17.11.9739
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 6150SE nForce 430 )
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.fixup.alternate.enabled: False
  • browser.history_expire_days.mirror: 180
  • browser.link.open_newwindow: 2
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.loadInBackground: False
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • font.default.x-western: sans-serif
  • font.name.sans-serif.x-western: Calibri
  • font.name.serif.tr: Verdana
  • font.name.serif.x-western: Verdana
  • font.size.variable.x-western: 18
  • general.useragent.extra.microsoftdotnet: ( .NET CLR 3.5.30729; .NET4.0E)
  • gfx.blacklist.suggested-driver-version: 257.21
  • network.cookie.prefsMigrated: True
  • network.dns.disablePrefetch: True
  • network.prefetch-next: False
  • places.database.lastMaintenance: 1367863470
  • places.history.expiration.transient_current_max_pages: 100646
  • places.history.expiration.transient_optimal_database_size: 75132764
  • places.last_vacuum: 1298076542
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: Yes
philipp
  • Top 10 Contributor
  • Moderator
3080 solutions 14317 answers

hello rennybosch, from the troubleshooting information you've submitted there's certainly nothing malicious going on in your firefox profile, you could update your plugins though...

can you specify how you are measuring the network traffic generated by firefox exactly?

for some general information on connections that firefox will initiate without your direct action also see How to stop Firefox from making automatic connections.

hello rennybosch, from the troubleshooting information you've submitted there's certainly nothing malicious going on in your firefox profile, you could [https://www.mozilla.org/en-US/plugincheck/ update your plugins] though... can you specify how you are measuring the network traffic generated by firefox exactly? for some general information on connections that firefox will initiate without your direct action also see [[How to stop Firefox from automatically making connections without my permission]].

Question owner

I downloaded a little app called Network Activity Indicator, which puts a little icon in the Taskbar. The icon blinks when there is network traffic.

If FF is open on a blank page or a page with very few links the indicator may blink for a few seconds but then stops. If FF is open on a busy page like Google News, the indicator blinks for 5-10 minutes before subsiding. That was what made me think there was a lot of prefetching going on.

I downloaded a little app called Network Activity Indicator, which puts a little icon in the Taskbar. The icon blinks when there is network traffic. If FF is open on a blank page or a page with very few links the indicator may blink for a few seconds but then stops. If FF is open on a busy page like Google News, the indicator blinks for 5-10 minutes before subsiding. That was what made me think there was a lot of prefetching going on.
cor-el
  • Top 10 Contributor
  • Moderator
12752 solutions 117198 answers

Does the throbber on the Tab bar stop spinning to indicate that the page has finished loading?

I've noticed that the places.last_vacuum shows a rather old date from 19 Feb 2011 and there are also some prefs that are no longer used.

  • places.last_vacuum: 1298076542

Maybe you should consider to reset the prefs or create a new profile (reset Firefox) to start with a fresh profile.

Does the throbber on the Tab bar stop spinning to indicate that the page has finished loading? I've noticed that the places.last_vacuum shows a rather old date from 19 Feb 2011 and there are also some prefs that are no longer used. *places.last_vacuum: 1298076542 Maybe you should consider to reset the prefs or create a new profile (reset Firefox) to start with a fresh profile.
philipp
  • Top 10 Contributor
  • Moderator
3080 solutions 14317 answers

ok, i can reproduce your observation - however when i use the tcpview tool from http://technet.microsoft.com/en-us/sysinternals/bb897437 it is apparent that the only steady tcp packets sent are between two local ports (this means they won't leave your computer), which is apparently necessary for the functioning of firefox on non-unix systems. the background is explained here for example: http://superuser.com/questions/71340/firefox-is-listening-for-incoming-connections-on-two-ports-why

you can right-click the network indicator icon in the taskbar, go to settings & select "indicate selected interface traffic" & then choose the network interface which connects you to the internet. then the blinking will really represent incoming/outgoing traffic that is actually coming from the internet.

ok, i can reproduce your observation - however when i use the tcpview tool from http://technet.microsoft.com/en-us/sysinternals/bb897437 it is apparent that the only steady tcp packets sent are between two local ports (this means they won't leave your computer), which is apparently necessary for the functioning of firefox on non-unix systems. the background is explained here for example: http://superuser.com/questions/71340/firefox-is-listening-for-incoming-connections-on-two-ports-why you can right-click the network indicator icon in the taskbar, go to settings & select "indicate selected interface traffic" & then choose the network interface which connects you to the internet. then the blinking will really represent incoming/outgoing traffic that is actually coming from the internet.

Question owner

The spinner does stop after a short while, but the blinker goes on and on and on . . .

The spinner does stop after a short while, but the blinker goes on and on and on . . .
cor-el
  • Top 10 Contributor
  • Moderator
12752 solutions 117198 answers

If the throbber starts working again then this usually means that some JavaScript is getting active on that page.

You can try to use the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) to see if new files are requested.

You can also try the Live Http Headers extension to check for pages that are requested and other data.

If the throbber starts working again then this usually means that some JavaScript is getting active on that page. You can try to use the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) to see if new files are requested. *https://developer.mozilla.org/en/Tools/Web_Console You can also try the Live Http Headers extension to check for pages that are requested and other data. *Live Http Headers: https://addons.mozilla.org/firefox/addon/live-http-headers/

Chosen Solution

Thanks Philipp, that's extremely helpful information. I changed the Setting in the activity indicator to Network traffic only, and the symptom has dramatically decreased. This completely alleviates my original concern. Problem solved.

Renny

Thanks Philipp, that's extremely helpful information. I changed the Setting in the activity indicator to Network traffic only, and the symptom has dramatically decreased. This completely alleviates my original concern. Problem solved. Renny