X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 20.0.1 crashes when accessing a MyHeritage web page (possibly involves Shockwave)

Posted

I have a problem with Firefox 20.0.1 under Windows 7 with Shockwave flash plug-in 11.7.700.169. When I access a web site "MyHeritage" with a page that displays my family tree, I repeatedly get a message "Video driver stopped working - NVIDIA driver ... has successfully recovered". If I disable Shockwave, Firefox / video driver will not crash. BTW - running Firefox in safe mode (add-ons disabled) stopped my NVIDIA driver from crashing. I had a second problem when playing videos (eg. YouTube) where Firefox crashed but updating some of my plug-ins fixed that particular problem. Any suggestions?

Chosen solution

hello walter, when the crash didn't happen in safe mode than it is a problem likely related to hardware acceleration. please try updating your graphics driver, or in case this doesn't solve the issue or there is no new version available at the moment, disable hardware acceleration in firefox > options > advanced > general.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Garmin Communicator Plug-In 4.0.4.0
  • Google Update
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Shockwave Flash 11.7 r700
  • GEPlugin
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • 5.1.20125.0
  • ABR_AUSkey Plugin Mozilla Component
  • CANON iMAGE GATEWAY Mycamera Plugin
  • CSI Plugin Mozilla Component

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • English (Australian) Dictionary 2.1.2 (en-AU@dictionaries.addons.mozilla.org)
  • Garmin Communicator 4.0.4 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • IE Tab + 2.04.20110724 (coralietab@mozdev.org)
  • IE Tab 2 (FF 3.6+) 4.12.22.2 ({1BC9BA34-1EED-42ca-A505-6D2F1A935BBB})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 6200
  • adapterDescription2:
  • adapterDeviceID: 0x0221
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 9.18.13.783
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 6200 )
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.theage.com.au/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.loadInBackground: False
  • browser.tabs.warnOnClose: False
  • dom.ipc.plugins.enabled.npietab2.dll: True
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • gfx.direct3d.checkDX10: False
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1367743664
  • places.history.expiration.transient_current_max_pages: 53676
  • plugin.disable_full_page_plugin_for_types:
  • privacy.cpd.cache: False
  • privacy.cpd.downloads: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

Chosen Solution

hello walter, when the crash didn't happen in safe mode than it is a problem likely related to hardware acceleration. please try updating your graphics driver, or in case this doesn't solve the issue or there is no new version available at the moment, disable hardware acceleration in firefox > options > advanced > general.

Question owner

Thanks for that suggestion - I have tried a number of things on the offending web pages and cannot crash Firefox after dropping hardware acceleration