X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Saving a password after once telling Firefox not to save.

Posted

I have a few sites where I initially told Firefox not to save a password but now I do want that username/password saved. How do I make Firefox ask again to save the username/password info?

I've checked these items: Password save option is "on" There are no items in the password exceptions list

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • GEPlugin
  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • npsitesafety
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • 5.1.20125.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Foxit Reader Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Amazon MP3 Downloader Plugin 1.0.17
  • Windows Activation Technologies Plugin for Mozilla
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

lizhenry 2 solutions 43 answers

Hi dave1310, you might try removing the cookie for that site. Go to Preferences, Privacy, and then click Remove Individual cookies. You should be able to filter the cookies to find and remove ones from the site you're visiting. Then try visiting it again. Good luck!

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Helpful Reply

hello, the only place where this information would be stored is the exceptions list under options > security which you already have identified. if firefox doesn't offer to save the password entered, this can also be due to the site specifying in its source-codet hat the browser shouldn't save passwords. for more information see Usernames and passwords are not saved.

you could use an addon like the following to circumvent such restrictions: https://addons.mozilla.org/firefox/addon/remember-passwords

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

Helpful Reply

You can inspect and manage the permissions for all domains on the about:permissions page.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


The website may be using autocomplete=off to prevent Firefox from saving and filling the name and password.

You can remove autocomplete=off with a bookmarklet to make Firefox save names and passwords and other form data.