X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I set downloads to automatically save instead of prompting me to open them?

Posted

I recently reset Firefox. Before whenever I downloaded a file, it automatically prompted me if I wanted to open the file or save it to my computer, with saving it to my computer preselected. This was fine because I almost never want to open these downloads automatically, and I like all my downloads to go into my downloads folder on a separate drive with much more space (not the temp folder on C:\). The option "do this automatically for files like this from now on" was useful for the rare file type that I would want to open automatically (usually because it's a very small music file or something).

Now every time I download virtually any file type, the prompt comes up with 'open the file' preselected, and "do this automatically for files like this from now on" greyed out. As a result, on more than one occasion, I have mistakenly clicked ok and opened huge files automatically after downloading (which has resulted in them popping open even hours later and playing automatically once the download finished). I'd like to be able to select "save it to my computer" and have it do this automatically, but that option is greyed out.

The help available seems to suggest going into options>Applications and changing the action for the appropriate content type, but: (a) not all the content types I download are listed, i.e. .mov, .mpeg, .rar, etc. (b) changing the action for the content types I do have (.wmv and compressed/zipped folder only) has done absolutely nothing.

I'm still prompted for each and every file I download, still preselected to open the file, with the "do this automatically for files like this from now on" still greyed out.

I'd like to change it to the way I had before, or at the very least automatically set all downloads to save into my downloads folder.

Chosen solution

Could you try copying your old mimeTypes.rdf file (the one in the Old Firefox Data) folder into your new profile folder? You can open your new profile folder quickly using:

Help > Troubleshooting Information > "Show Folder" button


Regarding the prefs.js comparison, I'd look for old preferences with either of these words in the name: download or helperApps.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Google Update
  • 5.1.20125.0
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPWLPG
  • McAfee MSC FF plugin DLL

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Session Manager 0.8.0.1 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • McAfee SiteAdvisor 3.3.1 ({B7082FAA-CB62-4872-9106-E42DD88EDE45}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7670
  • adapterDescription2:
  • adapterDeviceID: 0x675b
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 10-25-2011
  • driverDate2:
  • driverVersion: 8.911.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7670)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.onTop: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • font.internaluseonly.changed: False
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1366169625
  • places.history.expiration.transient_current_max_pages: 85968
  • plugin.disable_full_page_plugin_for_types: application/pdf,video/x-ms-wmv
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Helpful Reply

You can automatically save downloads without seeing the Open/Save/Cancel dialog in the Options:

orange Firefox button (or Tools menu) > Options > General > "Saves files to"

However, I can't think of a way to have the Open/Save/Cancel dialog always default to Save. I think mine suggests whatever I did last for the same type of content, but I haven't paid close attention.

I'm out of time to address the problem with "do this automatically" but there is one suggestion for why it could be grayed out in this article: Change what Firefox does when you click on or download a file.


Is it possible you had a download-related extension before? To compare settings and extensions, please retain the Old Firefox Data folder on your desktop. Aside from checking the extensions in there, it would be interesting to run a text file comparison on your currently active prefs.js file and your old one in that folder.

Question owner

"You can automatically save downloads without seeing the Open/Save/Cancel dialog in the Options:

orange Firefox button (or Tools menu) > Options > General > "Saves files to"

-It's already set like that. This is where I set the download folder location. The alternative is to always prompt me *where* I want to download my files.

"However, I can't think of a way to have the Open/Save/Cancel dialog always default to Save. I think mine suggests whatever I did last for the same type of content, but I haven't paid close attention. "

-That might be what Firefox used to do for me, but now it defaults on Open constantly no matter what I've selected last time.

"I'm out of time to address the problem with "do this automatically" but there is one suggestion for why it could be grayed out in this article: Change what Firefox does when you click on or download a file. "

-I saw that article before posting. I believe it suggests that the option might be greyed out because of the website I'm downloading the file from incorrectly the filetype. However this is a problem I have been having from every site I have downloaded from - and every site worked fine before my reset.

"Is it possible you had a download-related extension before?"

-I don't believe so. I can't see anything in the Old Firefox Data that looks like it.

"Aside from checking the extensions in there, it would be interesting to run a text file comparison on your currently active prefs.js file and your old one in that folder. "

-There's definitely a lot more listed in my old prefs.js file, but I don't know what I should particularly look for.

Thanks for helping, though!

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Chosen Solution

Could you try copying your old mimeTypes.rdf file (the one in the Old Firefox Data) folder into your new profile folder? You can open your new profile folder quickly using:

Help > Troubleshooting Information > "Show Folder" button


Regarding the prefs.js comparison, I'd look for old preferences with either of these words in the name: download or helperApps.

Question owner

Hmm...the following entries I found in my old prefs.js file but not in my new one with the word 'download' in its name:

user_pref("browser.download.manager.alertOnEXEOpen", false);
user_pref("extensions.dwpSwitcher.remoteScriptBaseURL", "http://download.divx.com/hiQ/scripts/");
user_pref("extensions.fnvfox.general.downloads.downloadsFolder", "C:\\Documents and Settings\\Owner\\My Documents\\Downloads");
user_pref("extensions.video.downloader.plugin@ffpimp.com.install-event-fired", true);
user_pref("print.print_downloadfonts", false);
user_pref("privacy.cpd.downloads", false);

I didn't see anything which said helperApps.

I'll try copying over the mimeTypes.rdf file and see if it makes a difference.

Modified by cor-el

Question owner

Yup, the old mimeTypes.rdf file seems to have worked. The prompt now defaults on "save file" and the checkbox for "do this automatically for files like this from now on" is clickable once more. Seems weird that a reset of Firefox would do something like that, but at least it works again for me. Thanks!

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

It appears something went wrong in regenerating the default mimeTypes.rdf file. First time I've heard of that, but without a lot of experimentation, I'm not sure we could get to the bottom of it.

timlturner 0 solutions 2 answers

I have just the opposite problem, how do I get Firefox to notify me when downloads are complete, show me where they are and offer me a chance to run them? It used to do it, now I often forget I downloaded something because it does it in the background and I have to go chase down the "download" folder which I can hardly ever find.

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Hi timlturner, if you are running Firefox 20 or later, there should be a green downloads arrow on the toolbar that lists your recent downloads. This article has more information: Find and manage downloaded files.

timlturner 0 solutions 2 answers

Oh cool, right in front of me... there just so much to see.  :-)

sago 0 solutions 1 answers

This was the solution I needed. Did a reset and when downloading RAR files the "do this automatically" was greyed out. Had a hard time even finding the current profile but your answer saved the day. Thanks.