Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why did my themes disappear when I updated Firefox?

  • 1 reply
  • 2 have this problem
  • 691 views
  • Last reply by cor-el

more options

I just updated Firefox after putting it off for quite a while. When I re-opened it, I noticed that it had reverted back to the default theme. So I went into Add-ons and tried to enable the theme that I'd been using before (fractal wonderland) but it said that the theme was already enabled. So I tried enabling another theme, but it had no effect. I tried restarting Firefox and even restarting my computer, but no matter what I did the theme wouldn't change. I really, really miss my old theme...is there any way that I can get it back?

Chosen solution

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

When you are in Private Browsing mode then the persona is disabled and you get the default theme.


You get a purple Private Browsing mask in the Firefox menu button or at the right end side of the menu bar (Linux: left end side of Tab bar) and "(Private Browsing)" appended to the Firefox title bar unless you are in permanent Private Browsing mode ("Always use private browsing mode").

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

When you are in Private Browsing mode then the persona is disabled and you get the default theme.


You get a purple Private Browsing mask in the Firefox menu button or at the right end side of the menu bar (Linux: left end side of Tab bar) and "(Private Browsing)" appended to the Firefox title bar unless you are in permanent Private Browsing mode ("Always use private browsing mode").