X
Tap here to go to the mobile version of the site.

Support Forum

how to stop animated gifs from blinking, ESC key no longer working

Posted

In previous versions of firefox, I could stop animated gifs from blinking by pressing esc; this is no longer working. Blinking makes me a little crazy, how do I make blinky things stop blinking? Please help!

In previous versions of firefox, I could stop animated gifs from blinking by pressing esc; this is no longer working. Blinking makes me a little crazy, how do I make blinky things stop blinking? Please help!

Chosen solution

You can look at the SuperStop extension that adds Shift+ESC:

You can also consider to animate only once by setting the image.animation_mode pref to "once" (default = "normal")


  • Bug 825486 – Escape no longer stops animated GIFs

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

Read this answer in context 10

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • HP Product Detection Plugin
  • HP Active Check Plugin
  • HP Pit Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • avast! WebRep 8.0.1483 (wrc@avast.com)
  • HP Detect 1.0.19.2 ({ab91efd4-6975-4081-8552-1b3922ed79e2})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • UserZoom Survey Tool 3.2 (userzoom_survey_tool@jetpack)
  • Xmarks 4.1.3 (foxmarks@kei.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16433
  • driverDate: 9-26-2012
  • driverDate2:
  • driverVersion: 9.17.10.2867
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 6
  • numTotalWindows: 6
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow: 2
  • browser.places.smartBookmarksVersion: 4
  • browser.search.suggest.enabled: False
  • browser.startup.homepage: http://b-d-s-monkey.livejournal.com/profile?socconns=pfriends&comms=cfriends
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.autoHide: True
  • browser.tabs.loadInBackground: False
  • dom.disable_open_during_load: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: True
  • extensions.lastAppVersion: 20.0.1
  • font.internaluseonly.changed: False
  • font.name.serif.x-western: Cambria
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1366479659
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: Yes
cor-el
  • Top 10 Contributor
  • Moderator
12916 solutions 118444 answers

Chosen Solution

You can look at the SuperStop extension that adds Shift+ESC:

You can also consider to animate only once by setting the image.animation_mode pref to "once" (default = "normal")


  • Bug 825486 – Escape no longer stops animated GIFs

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

You can look at the SuperStop extension that adds Shift+ESC: * https://addons.mozilla.org/firefox/addon/superstop/ You can also consider to animate only once by setting the image.animation_mode pref to "once" (default = "normal") *http://kb.mozillazine.org/Animated_images ----- *Bug 825486 – Escape no longer stops animated GIFs <i>(please do not comment in bug reports: [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html])</i>

Helpful Reply

OMG, you are my hero! THANK YOU! I don't know why, but animated gifs make me irrationally angry, and now my life will be peaceful again (at least when online)!

OMG, you are my hero! THANK YOU! I don't know why, but animated gifs make me irrationally angry, and now my life will be peaceful again (at least when online)!