Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When downloading a file that opens in another program, say a pdf-file, is it possible to open this program in the background so that I can continue browsing?


When downloading and viewing files, e.g. pdf- or Excel files, focus is automatically switched from Firefox to the pdf viewer or Excel when the files have finished downloading. It would be nice to be able to download and open multiple files without switching back and forth between Firefox and the other program for every time a new file is downloaded. Is it possible for Firefox to somehow "override" this behavior, so that I can continue browsing while the program opens in the background?

Thanks Jacob Hauge

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • 5.1.20125.0
  • VLC media player Web Plugin 2.0.2
  • Adobe Shockwave for Director Netscape plug-in, version
  • PDF-XChange Viewer Netscape Gecko Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • np-mswmp
  • Office Plugin for Netscape Navigator


  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/nb-NO/


  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)


  • incrementalGCEnabled: True


  • adapterDescription: Mobile Intel(R) 945 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x27a2
  • adapterDeviceID2:
  • adapterDrivers: igdumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 9-23-2009
  • driverDate2:
  • driverVersion:
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 945 Express Chipset Family)
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: about:blank
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365753722
  • places.history.expiration.transient_current_max_pages: 53429
  • places.last_vacuum: 1328608977
  • plugin.disable_full_page_plugin_for_types: application/vnd.fdf,application/vnd.adobe.xfdf,application/pdf
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 4
  • security.warn_viewing_mixed: False


  • User JS: No
  • Accessibility: No
  • Top 10 Contributor
2357 solutions 20872 answers

Helpful Reply

This might be a Windows 7 configuration difference, but I think this happens when the external program is launching for the first time. If the program was already open, it usually doesn't come to the front but instead its task bar icon flashes. Try leaving Adobe Reader and Excel minimized in the background and see whether that makes any difference.

Question owner

After some short testing I found that when Excel is already open, it does not come to the foreground. However, both Word and XChange Viewer (which i use for viewing pdf's) do.

So what you are saying is that this is possible to configure in Windows somewhere, or perhaps in the preferences in each program? It's not a very big deal actually, but I find sometimes that these small details can be a little bit annoying.

  • Top 10 Contributor
2357 solutions 20872 answers

I do think it's possible that there are some application settings which determine whether, like Microsoft Word, they leap to the foreground or stay in the background. However, I haven't found time to research them.

Question owner

Ok, thanks for your quick answers!