X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

"Well this is embarrassing........." message EVERY SINGLE time I open Firefox

Posted

I am now getting the 'well this is embarrassing...' message EVERY time I open Firefox; I have my Home page set to always open 9 tabs - these are the SAME tabs I have opened at start-up for about 2 years - WHY this annoying message now?! When I click 'close' the Home page opens with all the tabs with no problem, but the message is really irritating & doesn't seem to be telling me anything, as there isn't a problem with any of the tabs? NB: In case you ask 'why 9 tabs'?; these are essential websites I use every time I am browsing/working; I cannot keep opening them manually every time. Please advise why this message comes up as here seems to be no problem, & how I can get rid of it? Thanks.

Chosen solution

A likely cause is that you are first closing all Firefox windows and then close the Firefox application.

Some have reported that closing Firefox (Firefox > Quit) while the browser window is still open works for them.


  • Bug 845681 - Closing all windows and quitting Firefox afterwards leads to about:sessionrestore to be shown on next startup

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

Read this answer in context 7

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.6
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Amazon MP3 Downloader Plugin 1.0.17
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.

Application

  • Firefox 20.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0/Darwin/en-US/

Extensions

  • Adobe Contribute Toolbar 6.0 ({01A8CA0A-4C96-465b-A49B-65C46FAD54F9})
  • Dictionnaires français 4.10 (fr-dicollecte@dictionaries.addons.mozilla.org)
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6741
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 6750M OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: https://dub113.mail.live.com/default.aspx?id=64855&n=1065223863&fid=1#n=644469310&fid=1|https://mail.google.com/mail/u/0/?shva=1#inbox|https://mail.google.com/mail/u/1/#inbox|http://www.bbc.co.uk/weather/2643743|http://www.tfl.gov.uk/|http://www.france24.com/fr/afrique|http://www.wordreference.com/enfr/separate|http://uk.mg41.mail.yahoo.com/neo/launch?.rand=b3lnptmikig1c|http://www.rfi.fr/afrique|http://www.facebook.com/DerhanNKoudede
  • browser.startup.homepage_override.buildID: 20130326150557
  • browser.startup.homepage_override.mstone: 20.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0
  • font.name.serif.x-western: Calibri
  • font.size.variable.x-western: 15
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365490785
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96791 answers

You get this page if Firefox isn't closing properly.

Use Mac: "Firefox > Quit" (Linux: "File > Quit"; Windows: Firefox > Exit Firefox) to close Firefox if you are currently doing that by clicking the close X on the title bar.

You can also check for problems with the sessionstore.js and sessionstore.bak files in the Firefox Profile Folder that store session data.

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox Profile Folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost, so you will have to create them again (make a note or bookmark them).

Question owner

Thanks very much for your help; I deleted the 'sessionstore.js' file - couldn't see any other 'session' files in the Profile folder (except one ending in .bak? Thought I'd better leave that alone). Then I 'quit' Firefox completely & re-started the computer & it seems to have worked - it has also still opened all my tabs so I didn't have to re-set them all again. Well let's hope that's done the trick; fingers crossed!

finitarry 157 solutions 2177 answers

You can also preserve a collection of tabs by bookmarking them in a folder and then opening all in tabs at once. Right-click the tab bar and choose "Bookmark All Tabs", then give the folder a suitable name when asked. When you want your tabs back, select that folder, go to the bottom of the list and choose "Open All in Tabs".

Question owner

Thanks, that's helpful.

whisperycat 0 solutions 10 answers

Helpful Reply

Thanks for the workaround. However what's missing here is some acknowledgement of a new problem? This error message on start-up is affecting every laptop and Mac in our house. It wasn't happening before the last upgrade so what's been broken and what else is damaged? Firefox has been running so clunky and slow of late that I'm considering abandoning it until I read things have been fixed.

Question owner

That's interesting; I thought it was just me! You're right; it has started since the last upgrade. And in fact the solution above from Cor-el only worked for me for a while; I still intermittently get this message on opening FF. It tells me it is because of 'recently opened web pages'; but these are a variety of web pages that I have opened 100's of times already without this problem. Firefox; are you intending to fix this?

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96791 answers

Chosen Solution

A likely cause is that you are first closing all Firefox windows and then close the Firefox application.

Some have reported that closing Firefox (Firefox > Quit) while the browser window is still open works for them.


  • Bug 845681 - Closing all windows and quitting Firefox afterwards leads to about:sessionrestore to be shown on next startup

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

Question owner

Thanks again cor-el; well I tried this once & it worked - will see if it works over a longer period. I've moved the 'this solved my problem' badge to the above post!

Gankyll 0 solutions 3 answers

I am getting the same problem. Tried deleting the session.js and session.bak files but that didn't help at all. Problem persists. What to do?

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96791 answers

You can only do this if you close Firefox without closing the tabs first.
Otherwise you will have to disable Session Restore.

whisperycat 0 solutions 10 answers

Helpful Reply

Hi. As previously stated, what people are describing is buggy behaviour. This behaviour started after a recent update and it will continue until the bug fix has been rolled out. In the meantime, may I say "Thanks" to all Mozilla developers, who fix stuff like this in their own time. Thank you, wherever you are.

Modified by whisperycat

leetut 0 solutions 2 answers

ive got the same problem everytime i turn mac on and start firefox, i only have google set as a homepage

it started after updating recently

its now so annoying that i registered an account here and have actually started using safari, after not using it since i bought the mac!

so your probably losing users because of this

steveb49 0 solutions 2 answers

Interesting observation, and possible solution or workaround: I have had this same problem since installing version 20 on two OS X Lion computers. I finally said to heck with it and downgraded to version 19.something. I forgot however, to disable “automatically download and and install upgrades.” So, before I could stop it, I was again upgraded to version 20. However, after about five quits and restarts of Firefox the problem seems to be gone. I have not yet rebooted the computer so I'm by no means certain that the problem will not return.

sassysmom6 0 solutions 2 answers

Yes, after reading other replies, I tried closing FF without closing open windows and now when I turn on my computer, it goes right to Yahoo without the "Well this is embarrassing" memo!

steveb49 0 solutions 2 answers

Turns out this fix only lasted a day. Closing with windows doesn't work for me either.

clogan327 0 solutions 1 answers

I was having this symptom as well. However, I stumbled on a solution that may help. I am running Firefox 20 on a iMac running Lion v10.7.5 and receiving the "well this is embarrasing..." error message every time I started up Firefox from a dead stop. I had re-indexed Spotlight for an entirely different, unrelated problem I was having and then noticed that I also seemed to stop getting the error message from Firefox. I don't understand the relationship between re-indexing Spotlight and the Firefox symptom, but it seems to be holding up for a few days now. It certainly can't hurt to try re-indexing except to lose a little time while Spotlight sorts itself out. Naturally, this is only a band-aid fix, but it might be of some help.

finitarry 157 solutions 2177 answers

I do not understand the logic behind trying to restore a session after the history has been cleared. Why does FF 20 not check for the presence of history before trying to restore a session?

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96791 answers

You can restore a session if you have cleared the history manually because that doesn't effect storing session data.

You only can't do that if you clear the history via "Clear history when Firefox closes" because if that case there is not session to restore (session is considered as history in this case).

whisperycat 0 solutions 10 answers

That's really interesting. I'm still running Snow Leopard but I re-indexed and so far no replication of the bug. As I recall there used to be an option to 'open a private session' in the Tools drop down. Now there isn't. I can now do 'File -> New Private Window' which I don't think was there before? So it looks as if some work was done in this area, there is a bug on the loose and the re-indexing, as you say, might be a red herring.

To re-index on Snow Leopard do this -

http://support.apple.com/kb/HT2409

Modified by whisperycat

finitarry 157 solutions 2177 answers

What about "Clear Recent History" from the Tools menu? Is that not the same as "Clear History When Firefox Closes" from Preferences > Privacy? After either one there should not be any history or cache, the way I have those set.