X
Tap here to go to the mobile version of the site.

Support Forum

where is open links in new tab option as I dont want to right click?

Posted

I am using kubuntu 12.04 Fire fox 20. I want to open links in a new tab without right clicking I used to be able to this why can't I now?

I am using kubuntu 12.04 Fire fox 20. I want to open links in a new tab without right clicking I used to be able to this why can't I now?

Chosen solution

By the way, Firefox also offers you the option to open a link in a new tab using:

  • middle-click the link (e.g., mouse scroll wheel)
  • Ctrl+click the link (Mac: Command+Click)
Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • The IcedTea-Web Plugin executes Java applets.
  • Version 2.0.1 Twoflower, copyright 1996-2011 VideoLAN and Authorshttp://www.videolan.org/vlc/
  • Shockwave Flash 11.0 d1

Application

  • Firefox 20.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0/Linux/en-US/

Extensions

  • ChatZilla 0.9.90 ({59c81df5-4b7a-477b-912d-4e0fdf64e5f2})
  • DownloadHelper 4.9.14 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • FoxClocks 3.1.26 ({d37dc5d0-431d-44e5-8c91-49419370caa1})
  • Global Menu Bar integration 3.9 (globalmenu@ubuntu.com)
  • Globefish 1.4.1 (globefish@projects.6831.courses.csail.mit.edu)
  • Reader 4.3 ({20068ab2-1901-4140-9f3c-81207d4dacc4})
  • Text to Voice 1.10 (text2voice@vik.josh)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.6 (ubufox@ubuntu.com)
  • FlashResizer 1.4 ({C6F77964-B0B5-4953-A144-93051184EC0C}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Corporation -- GeForce 9500 GT/PCIe/SSE2
  • adapterDeviceID: GeForce 9500 GT/PCIe/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: NVIDIA Corporation
  • driverDate:
  • driverVersion: 3.3.0 NVIDIA 304.88
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- GeForce 9500 GT/PCIe/SSE2
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130329030832
  • browser.startup.homepage_override.mstone: 20.0
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365545816
  • places.history.expiration.transient_current_max_pages: 103660
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: Yes
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8885 solutions 72683 answers

The built-in option allows you to divert links that open in a new window to a new tab instead. This is for links pre-coded by the site to launch in a new window.

As far as I know, Firefox never had a feature to launch ALL links in a new tab. However, you might have been using an add-on for that. Tab Mix Plus is a popular extension you could try: Tab Mix Plus

In the Tab Mix Plus options, on the Links tab, you will see a drop-down to set this:

Force to open in new tab:

  • Nothing
  • All Links
  • Links to other sites

Does that do what you want?

The built-in option allows you to divert links that open in a new window to a new tab instead. This is for links pre-coded by the site to launch in a new window. As far as I know, Firefox never had a feature to launch ALL links in a new tab. However, you might have been using an add-on for that. Tab Mix Plus is a popular extension you could try: [https://addons.mozilla.org/en-us/firefox/addon/tab-mix-plus/ Tab Mix Plus] In the Tab Mix Plus options, on the Links tab, you will see a drop-down to set this: Force to open in new tab: * Nothing * All Links * Links to other sites Does that do what you want?
the-edmeister
  • Top 25 Contributor
  • Moderator
5425 solutions 40498 answers

Helpful Reply

Ctrl + Click

Ctrl + Click
jscher2000
  • Top 10 Contributor
8885 solutions 72683 answers

Chosen Solution

By the way, Firefox also offers you the option to open a link in a new tab using:

  • middle-click the link (e.g., mouse scroll wheel)
  • Ctrl+click the link (Mac: Command+Click)
By the way, Firefox also offers you the option to open a link in a new tab using: * middle-click the link (e.g., mouse scroll wheel) * Ctrl+click the link (Mac: Command+Click)
cor-el
  • Top 10 Contributor
  • Moderator
17771 solutions 160723 answers
See also: *http://kb.mozillazine.org/browser.link.open_newwindow *http://kb.mozillazine.org/browser.link.open_newwindow.restriction

Question owner

You musn't of been usinfg firefox for very long then buddy.

You musn't of been usinfg firefox for very long then buddy.

Question owner

Thanks, its better but not really the same.

Thanks, its better but not really the same.

Question owner

Thanks omni replyers "mouse scroll" works best for me now. I have an answer. Yay.

Thanks omni replyers "mouse scroll" works best for me now. I have an answer. Yay.
devildawg1 0 solutions 3 answers

I have another Machine with XP on it, I had to do a reinstall, because of a virus. and, after all updates installed. the firefox build that was on the machine would go to a new tab when I clicked on a link "using Ixquick search engine" it would open a new tab and go right to it with out having to doing anything. But now I have to right click on link to open new tab, and even then I will have to click on the new tab! why did it work right " meaning go to new tab" before I had to reinstall? By the way the center button trick on mouse does work good! Thanks

I have another Machine with XP on it, I had to do a reinstall, because of a virus. and, after all updates installed. the firefox build that was on the machine would go to a new tab when I clicked on a link "using Ixquick search engine" it would open a new tab and go right to it with out having to doing anything. But now I have to right click on link to open new tab, and even then I will have to click on the new tab! why did it work right " meaning go to new tab" before I had to reinstall? By the way the center button trick on mouse does work good! Thanks

Modified by devildawg1

jscher2000
  • Top 10 Contributor
8885 solutions 72683 answers

Hi devildawg1, search engines often have a setting to open results in a new window (which gets diverted to a new tab by default). This actually is a change embedded into the links in the page, and the search engine knows your preference based on a cookie.

Because you reinstalled, you likely would have lost your cookies. Can you visit the settings page and make sure you have the "new window" setting turned on?

https://ixquick.com/do/preferences.pl

If that isn't what you mean by link "using Ixquick search engine", could you explain your question in more detail?

Hi devildawg1, search engines often have a setting to open results in a new window (which gets diverted to a new tab by default). This actually is a change embedded into the links in the page, and the search engine knows your preference based on a cookie. Because you reinstalled, you likely would have lost your cookies. Can you visit the settings page and make sure you have the "new window" setting turned on? https://ixquick.com/do/preferences.pl If that isn't what you mean by ''link "using Ixquick search engine"'', could you explain your question in more detail?
devildawg1 0 solutions 3 answers

Hi jscher2000, I have all settings set the same way I did before. this machine is my main one with win 7 and set up the same way in every detail. not sure is that makes any difference, but when using this machine, when I click in a link and it will go right to and open the new tab. I think this build might be V22 but not sure. any way all settings are setup just as they were before the reinstall. meaning Browser and Ixquick, all setting the same as before. Thanks

Hi jscher2000, I have all settings set the same way I did before. this machine is my main one with win 7 and set up the same way in every detail. not sure is that makes any difference, but when using this machine, when I click in a link and it will go right to and open the new tab. I think this build might be V22 but not sure. any way all settings are setup just as they were before the reinstall. meaning Browser and Ixquick, all setting the same as before. Thanks

Modified by devildawg1

jscher2000
  • Top 10 Contributor
8885 solutions 72683 answers

Hi devildawg1, on the machine that's not behaving, try this general advice:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page and revisit the Ixquick settings page to create a fresh cookie. Does that help?

Hi devildawg1, on the machine that's not behaving, try this general advice: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Bypass Firefox's Cache Use Ctrl+Shift+r to reload the page fresh from the server. Alternately, you also can clear Firefox's cache completely using: orange Firefox button (or Tools menu) > Options > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page and revisit the Ixquick settings page to create a fresh cookie. Does that help?
devildawg1 0 solutions 3 answers

Hi jscher2000, I'll try that, if that doesn't help I'll get back to you. OK? Thanks for your help!

Hi jscher2000, I'll try that, if that doesn't help I'll get back to you. OK? Thanks for your help!
cor-el
  • Top 10 Contributor
  • Moderator
17771 solutions 160723 answers

You can also try to open a new window to see if the new window works better.

You can also try to open a new window to see if the new window works better.