X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Firefox won't save passwords. The option to save box is not ticked either.

Posted

Firefox will not save new password. I am not able to check the box for it to have the option to save new ones.

Modified by twinkstar

Chosen solution

Hello, do you have in privacy panel > History > CHECKED "Never remember history" ?

if yes, try to set it to "remember history" or "Use custom settings for history" and check it again.


thank you

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Conduit Plugin
  • np-mswmp
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • McAfee MSS+ NPAPI Plugin
  • 5.1.20125.0
  • Amazon MP3 Downloader Plugin 1.0.17
  • iTunes Detector Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_25 for Mozilla browsers
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • Firefox 20.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0/WINNT/en-US/

Extensions

  • Morning Coffee 1.35 (morningCoffee@shaneliesegang)
  • NoScript 2.6.5.9 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • ooVoo toolbar, powered by Ask.com 3.17.6.100013 (toolbar@ask.com)
  • Swag Bucks 10.15.0.562 ({8bdea9d6-6f62-45eb-8ee9-8a81af0d2f94})
  • Tab Mix Plus 0.4.0.5 ({dc572301-7619-498c-a57d-39143191b318})
  • Test Pilot 1.2.2 (testpilot@labs.mozilla.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • Skype Click to Call 6.7.0.12055 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0106
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 4-4-2011
  • driverDate2:
  • driverVersion: 8.15.10.2353
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.search.useDBForOrder: True
  • browser.sessionstore.resume_from_crash: False
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130326150557
  • browser.startup.homepage_override.mstone: 20.0
  • browser.urlbar.default.behavior: 1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://dts.search-results.com/sr?src=ffb&gct=ds&appid=100&systemid=2&apn_dtid=IME002&apn_ptnrs=AG2&apn_uid=7159090932474258&o=APN10641&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365543184
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.extensions-tabmix: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.csp.enable: False
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No

Question owner

Attachment to the question

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Chosen Solution

Hello, do you have in privacy panel > History > CHECKED "Never remember history" ?

if yes, try to set it to "remember history" or "Use custom settings for history" and check it again.


thank you

Question owner

Thank you!! That did the trick.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

you are welcome

tecarignan 0 solutions 3 answers

I have the same problem. In the Privacy panel I have History set to 'Remember history', and in the Security panel under Passwords I try to check 'Remember passwords for sites', but it won't stay checked. After restarting Firefox it is unchecked again. Running Firefox 21.0 on XP3.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello tecarignan, see: Preferences not saved

thank you

tecarignan 0 solutions 3 answers

Thanks ideato, I suspect Norton is the source as the issue seems to have begun around the same time as the last Norton update. I don't have Norton 360, I have NIS 20.3.1.22, so the instructions in the link don't apply for me. However the saved password issue is a problem for me only on a webmail site where I use multiple login IDs, and for that site I always let Firefox remember the passwords. On other websites with a single login ID, I use Norton's 'Vault' (login/password manager) to remember passwords. I'll just workaround the issue by configuring Vault to allow multiple logins on the webmail site.

mavfanjeff 0 solutions 6 answers

I'm having the same stupid problem. Tried setting everything as listed above. Nothing. I'm not going to try what ideato suggested too complicated. I just reinstalled firefox and this problem showed up. maybe I should switch to google chrome. I'm fed up with complicated computer problems.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96756 answers

You can try to create a new profile or reset Firefox.

When you reset Firefox then a new profile is created and some personal data (bookmarks, history, cookies, passwords, form data) is automatically imported and the current profile folder will be moved to the desktop (Old Firefox Data).
You will lose extensions and other customizations (toolbars, prefs) that you've made.

See also "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

mavfanjeff 0 solutions 6 answers

SOUNDS LIKE MORE COMPLICATED HEADACHES. Not everyone has a college degree in IT. I just reset firefox. Didn't help. Why should I have to "create a profile? either firefox will work or it won't. At this point IE is less annoying.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96756 answers

Hi mavfanjeff

Does remember passwords have a tick?

  • Tools > Options > Security: Passwords: [X] "Remember passwords for sites"
mavfanjeff 0 solutions 6 answers

remember passwords is checked. didn't help. I rolled back to firefox 23.0 didn't help.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96756 answers

Try to delete the signons.sqlite and key3.db files in the Firefox profile folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
mavfanjeff 0 solutions 6 answers

didn't work. user id and password for yahoo seems to be the only one that won't store.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96756 answers

The Yahoo login page uses autocomplete=off to prevent Firefox from saving and filling the name and password.

You can remove autocomplete=off with a bookmarklet to make Firefox save names and passwords and other form data.

You can create a bookmark with the JavaScript code via a right-click on the "Remember Password" link on the squarefree.com website and choose "Bookmark This Link" and select the "Bookmarks Toolbar" as the destination folder for easy access.

Create a new bookmark (name: Remember Password) on the Bookmarks Toolbar via the right-click context menu or in the Library and paste the JavaScript bookmarklet code including the javascript: label in its location field.

You need to use the "Remember Password" bookmarklet before or after filling the name and password field on the website with the login form, but before submitting the login form by clicking a button on the web page.

If the site is using autocomplete="off" then you see a number not equal to 0 (i.e. attributes were removed) in the pop-up alert from the bookmarklet and Firefox should offer to remember the name and password via a drop down dialog of the key icon that will appear on the location bar.

The version of the bookmarklet that is posted in the mozillaZine knowledge base article gives formatted output with line breaks that is easier to understand.

mavfanjeff 0 solutions 6 answers

once more in english? I'm pretty much giving up on this. I can't find any "bookmarklet


Can't find the java script either.

Modified by mavfanjeff

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96756 answers

Helpful Reply

The bookmarklet is this JavaScript code:

javascript:(function(){var ca,cea,cs,df,dfe,i,j,x,y;function n(i,what){return i+" "+what+((i==1)?"":"s")}ca=cea=cs=0;df=document.forms;for(i=0;i<df.length;++i){x=df[i];dfe=x.elements;if(x.onsubmit){x.onsubmit="";++cs;}if(x.attributes["autocomplete"]){x.attributes["autocomplete"].value="on";++ca;}for(j=0;j<dfe.length;++j){y=dfe[j];if(y.attributes["autocomplete"]){y.attributes["autocomplete"].value="on";++cea;}}}alert("Removed autocomplete=off from:\n"+n(ca,"form")+"\n"+n(cea,"form element")+"\n\nRemoved onsubmit from:\n"+n(cs,"form")+"\n\nAfter you type your password and submit the form, the browser will offer to remember your password.")})();

You can paste this code in the location field of a new bookmark (e.g. right-click on the Bookmarks Toolbar > New Bookmark), just like you would do with an URL like http://www.google.com You can name this bookmark "Remember Password"

An alternative is to use this extension:

Once you have saved the Yahoo password then you can disable this extension and only enable it when it is really needed to save a password.

mavfanjeff 0 solutions 6 answers

Don't know where to get the java script on my computer.Can't figure out where to paste it. the addon works. Thanks.

Modified by mavfanjeff