X
Tap here to go to the mobile version of the site.

Support Forum

How to fix bookmark icons from reappearing in new browser windows despite having bookmark deiconizer enabled (Mac Snow Leopard/Firefox 20.0).

Posted

Ever since Firefox upgraded to 20.0, my enabled deiconizer doesn't work when I open a new browser window. Using Mac/Snow Leopard. I want those bookmark toolbar icons to disappear permanently! They are nothing but clutter.

Ever since Firefox upgraded to 20.0, my enabled deiconizer doesn't work when I open a new browser window. Using Mac/Snow Leopard. I want those bookmark toolbar icons to disappear permanently! They are nothing but clutter.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Garmin Communicator Plug-in Version 4.0.4.0
  • 5.1.10516.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Garmin Communicator Plug-in Version 4.0.2.6
  • AmazonMP3DownloaderPlugin 1.0.16
  • Juniper Networks Safari Extensions
  • RealPlayer Plugin
  • npmnqmp 071706000001
  • Yahoo! Installer Plug-in provides application installation support
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Someone posted this review recently for the extension:

Update on Problems caused by Firefox version 20.0
I discovered that it is not necessary to exit the browser. Closing the open window and then opening a new window gets rid of the icons.

Does that work for you?

If not, there might be another way to suppress the folder and site icons using style rules.

Someone posted this review recently for the extension: '''Update on Problems caused by Firefox version 20.0'''<br> ''I discovered that it is not necessary to exit the browser. Closing the open window and then opening a new window gets rid of the icons.'' Does that work for you? If not, there might be another way to suppress the folder and site icons using style rules.
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Here is an ancient thread on the subject. It would be nice if someone could summarize it into a single post. How to remove icons from FF 4 Bookmarks Toolbar? Waste of space!

Here is an ancient thread on the subject. It would be nice if someone could summarize it into a single post. [https://support.mozilla.org/en-US/questions/792988 How to remove icons from FF 4 Bookmarks Toolbar? Waste of space!]

Question owner

Tried this several times, but the ONLY time a new window doesn't have those silly icons is when I initially open the program. All subsequent opening of new browser windows (not a new tab for the existing window) results in all tabs in that browser window to have the icons. I have to keep going to my Add-ons and disenable and re-enabling the deiconizer to get rid of them. Then the next time I open a new window, they reappear again. This has only started since I updated to FF20.

Tried this several times, but the ONLY time a new window doesn't have those silly icons is when I initially open the program. All subsequent opening of new browser windows (not a new tab for the existing window) results in all tabs in that browser window to have the icons. I have to keep going to my Add-ons and disenable and re-enabling the deiconizer to get rid of them. Then the next time I open a new window, they reappear again. This has only started since I updated to FF20.
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Obviously something has changed in Firefox 20 so that Deiconizer is not recognizing the launching of new windows. I don't have any suggestions for fixing that, and while Disabling/Re-enabling the extension works, there's no convenient way to access that as far as I can see.

There is an extension designed with the opposite purpose that you could use. It's called Roomy Bookmarks Toolbar and although was designed to feature primarily your icons, showing the text only on mouseover, it actually can be used the other way, to hide all the icons.

https://addons.mozilla.org/en-us/firefox/addon/roomy-bookmarks-toolbar/

The settings to hide icons are as follows:

  • Label Settings tab: check the box for Always show bookmark labels
  • Icons Settings tab: reduce the Favicon dimensions to 1

Not the most efficient solution, but seems to work.

Obviously something has changed in Firefox 20 so that Deiconizer is not recognizing the launching of new windows. I don't have any suggestions for fixing that, and while Disabling/Re-enabling the extension works, there's no convenient way to access that as far as I can see. There is an extension designed with the opposite purpose that you could use. It's called Roomy Bookmarks Toolbar and although was designed to feature primarily your icons, showing the text only on mouseover, it actually can be used the other way, to hide all the icons. https://addons.mozilla.org/en-us/firefox/addon/roomy-bookmarks-toolbar/ The settings to hide icons are as follows: * Label Settings tab: check the box for Always show bookmark labels * Icons Settings tab: reduce the Favicon dimensions to 1 Not the most efficient solution, but seems to work.
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

For the record, if you prefer to tweak the bar using style rules (either in a userChrome.css file or using the Stylish extension), here are some rules to work with:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
/* Hide icons for FOLDERS */
#PlacesToolbarItems .bookmark-item[type="menu"] .toolbarbutton-icon {
  display:none !important
}
/* Hide icons for SITES */
#PlacesToolbarItems .bookmark-item:not([type="menu"]) .toolbarbutton-icon {
  display:none !important
}
/* Add a bit of spacing */
#PlacesToolbarItems .bookmark-item {
  margin-left:3px !important; 
}
For the record, if you prefer to tweak the bar using style rules (either in a userChrome.css file or using the Stylish extension), here are some rules to work with: @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); /* Hide icons for FOLDERS */ #PlacesToolbarItems .bookmark-item[type="menu"] .toolbarbutton-icon { display:none !important } /* Hide icons for SITES */ #PlacesToolbarItems .bookmark-item:not([type="menu"]) .toolbarbutton-icon { display:none !important } /* Add a bit of spacing */ #PlacesToolbarItems .bookmark-item { margin-left:3px !important; }

Helpful Reply

Thanks for the suggestions. I think my next move is to contact Mozilla/FireFox to complain about this change and see if it can be fixed. If not, then I'll probably just switch to Safari. I lose patience with companies/programmers who do things like this. When I had programmers reporting to me (before I retired a few years ago), I would never let them get away with this sort of nonsense. User flexibility was a requirement.

Thanks for the suggestions. I think my next move is to contact Mozilla/FireFox to complain about this change and see if it can be fixed. If not, then I'll probably just switch to Safari. I lose patience with companies/programmers who do things like this. When I had programmers reporting to me (before I retired a few years ago), I would never let them get away with this sort of nonsense. User flexibility was a requirement.
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

I think my next move is to contact Mozilla/FireFox to complain about this change and see if it can be fixed.

I'm not sure we have enough information to know what to complain about. Firefox 20 introduced the ability to have both private browsing and regular windows in the same session. That probably involved changes that affect a number of different add-ons. But to figure out exactly which one is affecting Deiconizer is beyond me. Maybe the author knows how to fix it.

If not, then I'll probably just switch to Safari.

Well, if you must, but... I spent over an hour testing and documenting two viable workarounds for you, so please humor me and at least give one of them a try. Thanks.

''I think my next move is to contact Mozilla/FireFox to complain about this change and see if it can be fixed.'' I'm not sure we have enough information to know what to complain about. Firefox 20 introduced the ability to have both private browsing and regular windows in the same session. That probably involved changes that affect a number of different add-ons. But to figure out exactly which one is affecting Deiconizer is beyond me. Maybe the author knows how to fix it. ''If not, then I'll probably just switch to Safari.'' Well, if you must, but... I spent over an hour testing and documenting two viable workarounds for you, so please humor me and at least give one of them a try. Thanks.

Question owner

Understand - I'll take a crack at your first suggestion and see how I make out. Thanks for the efforts. What's really strange is that suddenly just now, without my having shut down, restarted or even closing Firefox, the problem has disappeared (after three days) - strange (maybe FF knew I wasn't happy with it). I'll keep your suggestion to use if/when this problem reappears. Thanks again.

Understand - I'll take a crack at your first suggestion and see how I make out. Thanks for the efforts. What's really strange is that suddenly just now, without my having shut down, restarted or even closing Firefox, the problem has disappeared (after three days) - strange (maybe FF knew I wasn't happy with it). I'll keep your suggestion to use if/when this problem reappears. Thanks again.
Wafelijzer 0 solutions 1 answers

Roomy Bookmarks Toolbar seems to work well. Instead of putting favicon dimensions to 1, you can also just click all the hide boxes. This seems to have the same effect.

A downside is that you loose the dropdown arrows, so that you cannot distinguish folders from direct links. Fortunately, there is a unicode character "▾" which you can add to the name of your folders.

Another downside is that you also lose the icons in your bookmarks toolbar menus.

Roomy Bookmarks Toolbar seems to work well. Instead of putting favicon dimensions to 1, you can also just click all the hide boxes. This seems to have the same effect. A downside is that you loose the dropdown arrows, so that you cannot distinguish folders from direct links. Fortunately, there is a unicode character "▾" which you can add to the name of your folders. Another downside is that you also lose the icons in your bookmarks toolbar menus.

Modified by Wafelijzer

rad2020 0 solutions 3 answers

If anyone is still struggling with this - Going on from jscher2000's post there is a very easy fix for this. No one should be switching to Safari..!

http://antennasoft.net/robcee/2012/04/20/bookmarks-deiconizer-userchrome-edition/

This is an article from the author of Bookmarks Deiconizer that walks you through exactly how to remove the icons by creating a file and placing it in a folder. It couldn't be much easier and it's completely safe!

Hope this helps someone who also hates the icons

If anyone is still struggling with this - Going on from jscher2000's post there is a very easy fix for this. No one should be switching to Safari..! http://antennasoft.net/robcee/2012/04/20/bookmarks-deiconizer-userchrome-edition/ This is an article from the author of Bookmarks Deiconizer that walks you through exactly how to remove the icons by creating a file and placing it in a folder. It couldn't be much easier and it's completely safe! Hope this helps someone who also hates the icons
firefoxren 0 solutions 2 answers

FF22 completely disabled the Add-on, now toggling on and off doesn't even work anymore

I tried the method at http://antennasoft.net/robcee/2012/04/20/bookmarks-deiconizer-userchrome-edition/ but it didn't work

Maybe I did something wrong? I copy the line of code, paste into TextEdit, saved as txt file, rename the extension to .css, copy file into profile folder, restart firefox, but all the icons still remain! Maybe FF22 broke this code again? Can someone who knows more about coding look into this?

I also tried the Roomy Bookmarks method, but it has problems with the spacing between each bookmark after folder icon is removed. I can't get it to spread out further even after using "normal" spacing.

FF22 completely disabled the Add-on, now toggling on and off doesn't even work anymore I tried the method at http://antennasoft.net/robcee/2012/04/20/bookmarks-deiconizer-userchrome-edition/ but it didn't work Maybe I did something wrong? I copy the line of code, paste into TextEdit, saved as txt file, rename the extension to .css, copy file into profile folder, restart firefox, but all the icons still remain! Maybe FF22 broke this code again? Can someone who knows more about coding look into this? I also tried the Roomy Bookmarks method, but it has problems with the spacing between each bookmark after folder icon is removed. I can't get it to spread out further even after using "normal" spacing.
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Hi firefoxren, maybe this step isn't documented: You need to create a new folder inside your profile folder named chrome. Then move the userChrome.css file into the chrome folder.

(In the olden days, Firefox set up a sample file in the chrome folder, but that isn't included any more, so you have to create the folder yourself.)

Hi firefoxren, maybe this step isn't documented: You need to create a new folder inside your profile folder named chrome. Then move the userChrome.css file into the chrome folder. (In the olden days, Firefox set up a sample file in the chrome folder, but that isn't included any more, so you have to create the folder yourself.)

Modified by jscher2000

firefoxren 0 solutions 2 answers

@jscher2000, aha, finally this fixes it forever, no more toggling on and off the Add-on ever since FF20!! thx very much!!

@jscher2000, aha, finally this fixes it forever, no more toggling on and off the Add-on ever since FF20!! thx very much!!
rad2020 0 solutions 3 answers

Helpful Reply

Hi I hope I can help as I am using FF22 with no bookmark icons! Start by opening the .css file in a browser and making sure it's the correct code. Make sure the name of the file is "userChrome.css" and it is in the profiles folder, then in the folder with 'default' in the name, then in the folder "chrome". I have attached an image that may help. Also if there is no "chrome" folder you must create one.

Hope this helps!

Hi I hope I can help as I am using FF22 with no bookmark icons! Start by opening the .css file in a browser and making sure it's the correct code. Make sure the name of the file is "userChrome.css" and it is in the profiles folder, then in the folder with 'default' in the name, then in the folder "chrome". I have attached an image that may help. Also if there is no "chrome" folder you must create one. Hope this helps!
rad2020 0 solutions 3 answers

Ah, just beaten to it haha

Ah, just beaten to it haha
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Hi rad2020, it's good you posted a screen shot from Finder. As you can see, mine is from Windows.

Hi rad2020, it's good you posted a screen shot from Finder. As you can see, mine is from Windows.
drlevbk 0 solutions 4 answers

jscher2000 & rad2020

I tried these steps but they did not work for me. Please, see attached image.

MacBook Air 13" 2011 / Mac OS 10.6.8 / Firefox 22

I created a new file in TextEdit. Pasted the code lines from the link. Saved the file to Desktop and renamed: "userChrome.css". Moved the file to a new "chrome" file and restarted Firefox - had not effect on the icons. If I open "userChrome.css" file, I can see new code lines created above the code lines that I pasted (I tried three time with the same result). I can not modify the lines created in this file.

jscher2000 & rad2020 I tried these steps but they did not work for me. Please, see attached image. MacBook Air 13" 2011 / Mac OS 10.6.8 / Firefox 22 I created a new file in TextEdit. Pasted the code lines from the link. Saved the file to Desktop and renamed: "userChrome.css". Moved the file to a new "chrome" file and restarted Firefox - had not effect on the icons. If I open "userChrome.css" file, I can see new code lines created above the code lines that I pasted (I tried three time with the same result). I can not modify the lines created in this file.

Modified by drlevbk

cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157383 answers

You need to save the userChrome.css file as plain text and not as RTF because that won't work.

You need to save the userChrome.css file as plain text and not as RTF because that won't work.
drlevbk 0 solutions 4 answers

In what file format should I initially save the file created in TextEdit before renaming it to .css format. There is no "plain text" option. I tried to save in .odt (open document text), but it does not work also. I attach the screen shots of formats available in TextEdit or should I use some other program to initially create the file?

In what file format should I initially save the file created in TextEdit before renaming it to .css format. There is no "plain text" option. I tried to save in .odt (open document text), but it does not work also. I attach the screen shots of formats available in TextEdit or should I use some other program to initially create the file?
cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157383 answers

You may not be able to change the format to plain text once saved as RTF, so try to create a new text file and see if that works.

You may not be able to change the format to plain text once saved as RTF, so try to create a new text file and see if that works.