X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

after latest update wmp plugin is missing in add-ons, but is still correct installed. Reinstalling wont work. What can i do?

Posted

I was lissening to online radio. Firefox needed to update. After the latest update the windows media player plugin dissapeared from the add-on list, while still being installed correct. I reinstalled it, but that didn't work. I replaced/deleted some files in firefox as suggested for similiar problems, but that didn't work either. Now I can't play wmp files anymore on firefox.

I hope u can help me solve this problem.

Chosen solution

Found a solution:

Go into about:config and change plugins.load_appdir_plugins from false to true. Apparently FF21 sets this value to false by default causing it to not detect plug-ins installed in this manner.

Read this answer in context 80

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Picasa plugin
  • Shockwave Flash 11.6 r602
  • GEPlugin
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • 5.1.20125.0
  • McAfee MSC FF plugin DLL
  • DivX VOD Helper Plug-in
  • DivX Web Player version 2.0.3.4
  • myVR 3D Framework
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/nl/

Extensions

  • Feedback 1.2.2 (testpilot@labs.mozilla.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.1 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Freemake Video Converter Plugin 1.0.0 (fmconverter@gmail.com) (Inactive)
  • McAfee ScriptScan for Firefox 14.4.1 ({D19CA586-DD6C-4a0a-96F8-14644F340D60}) (Inactive)
  • McAfee SiteAdvisor 3.3.1 ({B7082FAA-CB62-4872-9106-E42DD88EDE45}) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 2600 XT
  • adapterDescription2:
  • adapterDeviceID: 0x9588
  • adapterDeviceID2:
  • adapterDrivers: aticfx32 aticfx32 atiumdag atidxx32 atiumdva
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 7.0.6002.18592
  • driverDate: 1-26-2011
  • driverDate2:
  • driverVersion: 8.821.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 2600 XT)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130401192816
  • browser.startup.homepage_override.mstone: 21.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • gfx.direct3d.checkDX10: False
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 87175
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

For the record, here's the related bug report (Status: RESOLVED WONTFIX) if anyone's interested:

  • Bug 872325 - Windows Media Player firefox plugin stops working after upgrade to v21.0

Please don't comment in bug reports unless you have something constructive to add - see https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96858 answers

You can alternatively move plugins from "<install>/plugins/" to <install>/browser/plugins/ to make Firefox find them again.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Note that programs shouldn't install plugins in the Firefox program folder, but use other means (i.e. use the Windows registry) to make Firefox find plugins.

brendajones4life 0 solutions 3 answers

Would someone kindly tell me how to fix this problem, in detail since I am not a technical guru like you guys?

I read the fix about changing some flag from false to true, but how to do this?

Will share the solution with my other friends since we use the same programs.

brendajones4life 0 solutions 3 answers

Forgot to mention for Windows Vista

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96858 answers

You can set the plugins.load_appdir_plugins pref to true on the about:config page to make Firefox scan the "<install>/plugins/" directory for plugins like the WMP plugin (np-mswmp.dll).

Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar.

  • If you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily
  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref
  • preferences can be created via the right-click context menu: New -> String, Integer, Boolean
brendajones4life 0 solutions 3 answers

WOW - It worked. Kudos and many, many thanks!!!!

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96858 answers

You're welcome Brenda.

nhcatsteve 0 solutions 1 answers

I'm the systems admin for a small radio station. The following options on this issue I don't consider viable:

1. Asking all my listeners to change a setting buried deep within firefox.

2. Asking them to refrain from updating firefox, until firefox restores compatibility with windows media player activex.

3. Firefox developers expecting microsoft (a competitor) to go out of their way and release a new version just to ensure their plugin is still fully compatible with firefox.

I regret to report that this disappointing incident is forcing me to wonder if free software is too cheap. Playing mp3 audio is basic functionality... this should have been tested before the update hit the release channel.

Modified by nhcatsteve

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3019 answers

This was changed due to a security issue. You can link your listeners to this article: Windows Media or other plugins stopped working after Firefox update

jessbee 2 solutions 25 answers

I have same problem, Can t hear conference calls that require media player and the plug in has disappeared. I tried changing to true and was successful in changing it, but still the plug in is not in my list of plug ins. Used plug in installer from introperablity bridges that was recommended but had some problem in deciding if I needed repair or change and if change, what to change. Net result is that I still don't have wpm plug in working and can't find it.

Edited two hours later:: I did the about:config solution by opening a new tab and going from there. I had previously typed about:config in the start box like I did with msconfig, but once I typed about:config in the new tab and followed the instructions I was able to change the value to true. This did not solve the problem. I got help from jscher2000 who suggested I remove the old plug in using the removal button on the installation wizard, and once I did that and then te installed windows media player it showed up on my plug ins and I could hear my conference.

Modified by jessbee

jessbee 2 solutions 25 answers

Hello Feer56: The fix didn't work for me. I changed the value to true as set forth in the article you recommend, restarted the computer and firefox, checked to see value was still set to true, and I can't use windows media player or get the plug in for WMP to appear in my list of plug ins.

Modified by jessbee

jessbee 2 solutions 25 answers

I agree with nhcatsteve. I have same problem, tired fix, and it didn't work. Way too complicated. We had WPM before the update, now it is gone and we can't get it back. The only way to listen to conferences using windows media player is to use another browser. I can see why people are upset. We had a working WPM, we did nothing, now it isn't working and we can't get it to work. We tried downloading the approved plug in from microsoft using the approved download wizard, and the plug in didn't down load. We tried going deep into the workings of windows and risked voiding our warranty to follow the approved firefox fix and it didn't work. The only thing that works is using another browser. There is no way a business like a radio station can get all its customers or listeners to make changes using about:config. That may be all right for a individual user, but not for a business with many users. People running firefox need to understand that a browser is not a holy grail, it is just a way to get to a website, and if after you get to the website using the browser prevents you from using the website, the browser is useless. It doesn't matter if you get there a half second faster, if you can't do what you need to do at the web site. You just use another browser that does the job even if it doesn't have as many features. As they told Charlie Parker after he showed up six hours late: somebody else who can can't play as good, but who showed up and did an adequate job got the work.

Modified by jessbee

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96858 answers

This is is not caused by fixing a security issue, but part of separating browser and platform resources for the metro version and has caused some files and folders to get moved to the browser folder.

  • Bug 755724 - (metro-build) Split platform and app resources up so that they can be loaded individually

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

jessbee 2 solutions 25 answers

I finally fixed it by removing the old plug in using the installation wizard and the re installing windows media player. I had to do this after changing the value to true, and still not having firefox find the old plug in which was working before the last update. So for me it was a two step process: 1. Change value to true using about:config 2. Removing and re installing the plug in.

jessbee 2 solutions 25 answers

Hello Corel: The Ghacks article sets forth the solution we have come to here. It also says "It is preferred though to move the plugins into the new folder instead." Wouldn't all this be solved if firefox moved the plug ins into the new folder for its users? Is this possible? I and many others don't feel confident moving things into folders.

jessbee 2 solutions 25 answers

Corel's solution on 5/17/2013 at 5:45 PM is correct but here might be an easier way after you get to the search box. 1. In search box type in plug ins When list appears find "plugins.load_appdir_plugins 2 Double-click plugins.load_appdir_plugins to switch its value from false to true. This will take effect after you restart Firefox.

Modified by jessbee

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96858 answers

If you would have to reset Firefox for some reason then you lose pref settings saved in the prefs.js file like this one, so you will have to change this pref once again. If you would copy the plugin files to the browser\plugins folder then they will always be found and you won't have to remember which pref to change.

jessbee 2 solutions 25 answers

Hello Corel. Thank you for the response. Is the browser/plugins folder at C:\Program Files (x86)\Mozilla Firefox\Plugins? I do see the wpm file there. Does that mean it won't go away the next time there is an update or I reset firefox. If not please list step by step instructions for how to copy the plugin files to the browser\plugins folder as you recommend, or refer us to the article that does. I was able to follow your post of May 17 up to the point where you got to the search box, but got lost when you started talking about preferences.. Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96858 answers

Yes. All search engines installed in the browser\searchplugins folder will automatically appear in a new profile. For an existing profile you may have to delete the search.json file in the Firefox profile folder to reset the search engines to the default and make Firefox pick new search engines.

Biddie 0 solutions 1 answers

I did this, Double-click plugins.load_appdir_plugins to change it's value to True. And then the plugin showed in my plugins window. Now I tested it at Windows Media Test Got popup saying "VLC Media plugin crashed. Then disabled vlc plugin, wolla now it works fine. In my case I will have to uncheck the windows media associations before enabling vlc again.