X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

after latest update wmp plugin is missing in add-ons, but is still correct installed. Reinstalling wont work. What can i do?

Posted

I was lissening to online radio. Firefox needed to update. After the latest update the windows media player plugin dissapeared from the add-on list, while still being installed correct. I reinstalled it, but that didn't work. I replaced/deleted some files in firefox as suggested for similiar problems, but that didn't work either. Now I can't play wmp files anymore on firefox.

I hope u can help me solve this problem.

Chosen solution

Found a solution:

Go into about:config and change plugins.load_appdir_plugins from false to true. Apparently FF21 sets this value to false by default causing it to not detect plug-ins installed in this manner.

Read this answer in context 80

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Picasa plugin
  • Shockwave Flash 11.6 r602
  • GEPlugin
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • 5.1.20125.0
  • McAfee MSC FF plugin DLL
  • DivX VOD Helper Plug-in
  • DivX Web Player version 2.0.3.4
  • myVR 3D Framework
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/nl/

Extensions

  • Feedback 1.2.2 (testpilot@labs.mozilla.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.1 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Freemake Video Converter Plugin 1.0.0 (fmconverter@gmail.com) (Inactive)
  • McAfee ScriptScan for Firefox 14.4.1 ({D19CA586-DD6C-4a0a-96F8-14644F340D60}) (Inactive)
  • McAfee SiteAdvisor 3.3.1 ({B7082FAA-CB62-4872-9106-E42DD88EDE45}) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 2600 XT
  • adapterDescription2:
  • adapterDeviceID: 0x9588
  • adapterDeviceID2:
  • adapterDrivers: aticfx32 aticfx32 atiumdag atidxx32 atiumdva
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 7.0.6002.18592
  • driverDate: 1-26-2011
  • driverDate2:
  • driverVersion: 8.821.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 2600 XT)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130401192816
  • browser.startup.homepage_override.mstone: 21.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • gfx.direct3d.checkDX10: False
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 87175
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3020 answers

If this issues pertains to an add-on being broken, please contact the developer of the add-on so they can release and update and keep up to date with new releases Firefox has every 6 weeks.

Thanks!

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Try to delete the pluginreg.dat file in the Firefox Profile Folder and maybe addons.sqlite as well to reset the plugin registry databases.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

You can (re)install the new WMP plugin (np-mswmp.dll)

Question owner

To feer56: Thank u for the advice. The wmp plugin is dated from 2007. I don't think this add-on is broken or not suitable after the latest update, because many users would then post this issue.

To cor-el: Thanks for the answer, however it didn't help. And when I tried to add the plugin manually firefox freezes or says the exe file is corrupted. I am almost sure the file is ok. I downloaded it from multiple sources but firefox refuses them all. I am wondering what could cause this.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

It is possible that anti-virus software is corrupting downloaded files or is otherwise interfering with downloading files.

Try to disable the real-time (live) scanning of files in your anti-virus software temporarily to see if that makes downloading work.

See:

Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3020 answers

I may have to disagree, if it is dated back to 2007 then chances are that there may be many issues. We receive reports of addons breaking all the time and so we get reports all the time.

Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3020 answers

Please contact the developer for more assistance.

Question owner

I Think I have solved the problem. I didn't pay much attention to the version number. I Found out that I had Firefox 21. however app.update.channel was set to release. I installed version 20 and wmp plugin is working. I hope it won't update to 21 until it becomes a release version.

feer56 and cor-el; thanks for your help.

anuswara 0 solutions 77 answers

After upgrading to FF21, the WMP plugin disappears from the addon list, not suitable. Ok until FF20. Please fix this behaviour, otherwise a lot of websites become unuseful. Thanks.

Modified by anuswara

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Try to delete the pluginreg.dat file in the Firefox Profile Folder and maybe addons.sqlite as well to reset the plugin registry databases.

See Re-initializing the plugins database:

MarkRH 1 solutions 2 answers

Same problem. After updating to FF21, the Microsoft® Windows Media Player Firefox Plugin 1.0.0.8 np-mswmp is no longer listed in plug-ins as either enable or disabled.

Reinstalling the plug-in and deleting the pluginreg.dat file had no effect. Windows 7 Pro/SP1 64bit.

anuswara 0 solutions 77 answers

This is a bug! a lot of people does experience this issue...

MarkRH 1 solutions 2 answers

Chosen Solution

Found a solution:

Go into about:config and change plugins.load_appdir_plugins from false to true. Apparently FF21 sets this value to false by default causing it to not detect plug-ins installed in this manner.

Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3020 answers

You must contact developers to push an update for their plugins. We do NOT make updates nor do we push them. We only notify and inform them. The developers have more than enough time to make their plug-ins work. Please check if your plug-in is up to date as if it is out of date then obviously the plug-in will not work. I hope that you will understand this.

Thank you!

anuswara 0 solutions 77 answers

Helpful Reply

No, I dont agree with you! absolutely! this is NOT due to the plugin developer, but to Mozilla. Mozilla modified the behaviour. Mozilla should to repair the issue! the plugin is NOT blacklisted by mozilla!!! therefore.... I am worried about your reply.

Modified by anuswara

anuswara 0 solutions 77 answers

Since 2007 it has been not updated ever, but it worked until FF20, therefore.... ;) I dont understand why the Firefox developers encourage the users to switch to other browsers with this kind of replies.

Modified by anuswara

Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3020 answers

Mozilla did NOT make any major changes. Every updates, plugins break due to security updates and fixes and other nits and pieces. Mozilla does not have the power to create a new plugin version nor update it on behalf of the developers. It is up to the developers to put an update out to fix. We cannot fix it because it has nothing to do with us making it not work. You reported this a while back using version 21. If you were using version 21, wouldn't the plugin have worked since you were not using version 20? Plug-ins break eventually and it's not because Mozilla doesn't care about it but developers are given more than enough time to fix or release updates for their plug-ins. We cannot do anything about the behavior, version 21 is released with no major changes so it is only up to the developers to fix the issue.

anuswara 0 solutions 77 answers

oh mozilla did NOT make changes, except this: >>o into about:config and change plugins.load_appdir_plugins from false to true. Apparently FF21 sets this value to false by default causing it to not detect plug-ins installed in this manner.

anuswara 0 solutions 77 answers

wouldn't the plugin have worked since you were not using version 20?


oh my god.

Digdog9 0 solutions 1 answers

>> Found a solution: Go into about:config and change plugins.load_appdir_plugins from false to true.

BINGO! Thank you. How ridiculous that I have spent hours of frustration all because Mozilla broke the plugin load config in their new version...

And NO, the "developer" in this case should not be required to provide an Update to Mozilla.... the DEVELOPER of Windows Media Player IS MICROSOFT. Is this behavior now expected from new FF versions ??

anuswara 0 solutions 77 answers

but the expert say that mozilla did not change nothing in FF21... (nothing.... except this key!)  ;)