X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 20.0 Private Browsing Holds on to Logins

Posted

Previous to Firefox 20.0, you would click "Start Private Browsing" (I can't remember the exact wording) and for example, login to Site X. When you were finished, you would click "Stop Private Browsing." Later in the day, you would click "Start Private Browsing" and go to Site X. Site X would not show you logged-in.

That's no longer the case.

In Firefox 20.0, you click "New Private Window" and login to Site X. When you're finished, you click on Close (the x). Later in the day, you click "New Private Window" and go to Site X. Site X still shows you logged-in from the previous private session.

So "Private Browsing" is not actually private.

The only way to ensure that this doesn't happen if you go to File > Exit but that shuts down everything including non-private browsing.

Modified by Yael K. Miller

Chosen solution

I have just managed to solve this problem but I have no idea why it solved it.

  • Disabled all my add-ons
  • Enabled them one-by-one (testing the issue)

All's well for now. Even with Norton Toolbar enabled which I thought might have been an issue.

Here's hoping it stays fixed.

Read this answer in context 9

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • Google Update
  • 5.1.20125.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • ActiveTouch General Plugin Container Version 105

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

jscher2000
  • Top 10 Contributor
2366 solutions 20922 answers

Helpful Reply

I just tried this:

  • New Private Window
  • gmail.com - redirects to login page
  • login to Google account
  • search inbox
  • close window (using the "red X")
  • New Private Window
  • gmail.com - redirects to login page
  • No history from previous session on the History menu

This was with my default cookie permission setting for all *.google.com of Allow for Session. In other words, I do not keep Google cookies across sessions; they expire when the browser closes.

I went into about:permissions and changed my cookie permission for all *.google.com domains to Allow. I repeated the test and got the same result.

So I'm not sure why yours persisted information across your sessions. Do you use any session management add-ons that might play a role?

Question owner

What do you mean by "session management" add-ons?

jscher2000
  • Top 10 Contributor
2366 solutions 20922 answers

What do you mean by "session management" add-ons?

For example, there is an extension named Session Manager that stores information about your Firefox session separately from Firefox's own session restore file.

There also are add-ons that keep track of data entry on forms for purposes of crash recovery, such as Lazarus.

Since the concept of individual windows being private or non-private is new in Firefox 20, any add-on that stores browser data and hasn't been updated to distinguish between the windows might accidentally keep some private data.

Question owner

No, I don't use session management add-ons.

Chosen Solution

I have just managed to solve this problem but I have no idea why it solved it.

  • Disabled all my add-ons
  • Enabled them one-by-one (testing the issue)

All's well for now. Even with Norton Toolbar enabled which I thought might have been an issue.

Here's hoping it stays fixed.

Modified by Yael K. Miller

jscher2000
  • Top 10 Contributor
2366 solutions 20922 answers

Air bubbles, stray electrons... sometimes there is no explanation!