Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable command ⌘ + scroll zooming in firefox 20 on mac?

  • 7 replies
  • 21 have this problem
  • 14090 views
  • Last reply by gslrider

more options

If I scroll (using two fingers on the trackpad) while holding the command ⌘ my page zooms in and out. How do I disable this?

Chosen solution

Sorry, after a little more research, I think on MacOS the relevant setting is for the "meta" key not the "ctrl" key.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste meta and pause while the list is filtered

(3) Double-click mousewheel.with_meta.action and enter the desired value from the following list, then click OK.

0: Nothing happens
1: Scrolling contents
2: Go back or go forward, in your history
3: Zoom in or out

Any luck?

Read this answer in context 👍 52

All Replies (7)

more options

I believe this is linked to Firefox's setting for the "mouse wheel". Check out the following thread and see whether that helps: control key (ctrl) and scrolling issue (for Windows 8, but same principle).

more options

Nope, didn't change anything

more options

Chosen Solution

Sorry, after a little more research, I think on MacOS the relevant setting is for the "meta" key not the "ctrl" key.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste meta and pause while the list is filtered

(3) Double-click mousewheel.with_meta.action and enter the desired value from the following list, then click OK.

0: Nothing happens
1: Scrolling contents
2: Go back or go forward, in your history
3: Zoom in or out

Any luck?

more options

Yes!

Thank you! Have a internetcookie on me :)

more options

Can I just change this shortcut ? For example - scroll zooming + cmd + shift or another button, I like this option but not always.

Modified by arnsoares

more options

You can modify the action for any modifier key that you see on the about:config page.

mousewheel.default.action
mousewheel.with_alt.action
mousewheel.with_control.action
mousewheel.with_meta.action
mousewheel.with_shift.action
mousewheel.with_win.action

See also:

0: Nothing happens
1: Scrolling contents
2: Go back or go forward, in your history
3: Zoom in or out
more options

Thanks jscher2000, I've been trying to figure out how to disable the mouse scroll wheel zoom in Firefox. Your tip worked like a charm.

Modified by gslrider