X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

we are getting a pop up that says we need to install flash player plug in. we tried everything, nothing works

Posted

we can't play any games. it says we need to install additional plug in, for flash player. when we attempt to install, it says we already have the newest version installed. but nothing works. can not find the install anywhere. we had a computer person working on it and she could not figure it out. she tried everything. Do we need to uninstall firefox and reinstall it?

Chosen solution

thank you all for your help!! our computer is fixed... YEAH!!!!

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • npsitesafety
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • 5.1.20125.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Omar_Sega 0 solutions 4 answers

Hi bonnienoce ! Check if the Flash plugin is enabled, to do this you need to: Press Ctrl+Shift+A > Go to the Plugins Tab > Enable Shockwave Flash Player.

Please tell us if this worked

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Your plugins list is not reporting that you have Flash -- you can see the list your browser makes available to websites by clicking "More system details" next to your question.

If you open the following page, is "Shockwave Flash" disabled? The disabled plugins cluster toward the bottom.

orange Firefox button (or Tools menu) > Add-ons > Plugins category

Please note that Shockwave for Director is a different plugin that plays an older format of media.

If it's not there at all, how did you confirm that you have it installed? Please note that Adobe has separate downloads for IE and for "Other browsers". If you visit Adobe using IE, you need to click the "Do you have a different operating system or browser?" link in order to get the download for Firefox.

It's this page (make sure to uncheck any unwanted extras you're offered):

http://get2.adobe.com/flashplayer/otherversions/

Does that work any better?

Question owner

thank you Omar, the shockwave is enabled, but it says it is shock wave director netscape plug in version 12.0. Is that the wrong plugin??

Question owner

ok, I disabled shockwave director, and installed shock wave player. only that didn't work, I am not very good with computers. my husband is at work. I am going to wait untill he gets home and let him try. thank you so much for your help. may have to ask more questions LOL

Question owner

my husband kept trying. with no success. he took the flashplayer for director out, and it loaded the same thing back in. he installed adobe air. when we try to install missing plug in, half way thru it says that the newest one is installed, then when we go back to adobe it says that it failed to install. don't know what to do next. please help if you can. thank you he said to ask if we should uninstall firefox and reinstall

Modified by bonnienoce

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Could you review your plugins list and see which (if any) Adobe/Shockwave plugins you have now:

orange Firefox button (or Tools menu) > Add-ons > Plugins category


When you go to the following download page and choose "Flash Player 11 for Other browsers" and download the installer, what is the actual name of the file that gets saved?

http://get.adobe.com/flashplayer/otherversions/

Mine's called "install_flashplayer11x32_mssd_aih.exe"


Occasionally software installs are not completed until you restart Windows. You might want to try that at some point if you haven't already.


Adobe has a cleanup tool described in this article where you can scrub out all Flash versions and start again. Flash Plugin - Keep it up to date and troubleshoot problems


I do not recommend uninstalling Firefox.

You can refresh your Firefox installation or update to Firefox 20 by running the Firefox installer. You do not need to remove the old version first. You can get that download here:

https://www.mozilla.org/en-US/firefox/fx/#desktop

Question owner

we still get the version we are trying to install is not the most current, then it says the current one is installed. then a pop up says, go to player download center. it is the same one you have. at the download center it says it failed to install. we refreshed firefox, still does the same.. we appreciate your help, but nothing works.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Do not confuse the Shockwave for Director plugin and the Shockwave Flash Player plugin.
Both are different plugins.

You can check the version of the current Flash player here:

Latest Flash player versions here:

Question owner

my friend is a computer engineer. she hasn't had a chance to see your post yet, or try what you suggest.. will let you know if it works after she tries. thank you!!

Chosen Solution

thank you all for your help!! our computer is fixed... YEAH!!!!