X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

my cookies are disabled

Posted

ive tried to delete my cache and cookies, restart firefox / cp , unchecked third party cookies, custom cookie setting with allow cookies from sites, deleted corrupted files so what can it be?

also ive tried enabling cookies on other browsers but its the same problem.

Modified by nobes

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • 2.1.3
  • 0.3
  • Uplay PC Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.0.2
  • Unity Player 3.5.6f4
  • npsitesafety
  • Pando Web Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

If all of your browsers fail to send the expected cookies to websites, then your security or privacy software might be actively intercepting and stripping them.

Could you check your external security and/or privacy software settings to see whether they are blocking cookies? If you can't find it, maybe reply with the brand(s) and others familiar with the software could help you locate that in their settings.

Question owner

i could be that, but i just installed a new firewall like yesterday and dont even have an antivirus program installed atm, for a while actually....

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

You need antivirus. For now, why not use Microsoft's free offering until you have time to research it more? http://windows.microsoft.com/en-us/windows/security-essentials-download

Some firewall programs may block cookies. It's worth checking.

Question owner

yea i did need one but just havnt bothered but i got the microsoft but i still havnt solved the problem, what else can it be? :S

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96698 answers

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

careyt39 0 solutions 11 answers

Same problem, starting Firefox from a shutdown and within seconds a tab comes up 'Please enable cookies'

Checking Tools > Options > Privacy I find that the settings I've made, ie, History = 'Use custom settings for history', 'Accept cookies from sites' , 'Accept third-party cookies=Always', 'Keep until 'they expire' keep getting reset despite any w-a I've been able to find.

This all started with FF 23.0.1

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96698 answers

Which web page is causing this error?

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


You can also check if DOM Storage is enabled.

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

Hi careyt39, I think those three cookie settings are the default settings. What do they get changed to?

(Note: if you select all default settings, the drop-down may switch from showing Use custom settings to Remember history.)

You might also check this article regarding a configuration file that can override your preferences at startup: How to fix preferences that won't save.

Extensions also are a possible cause for changed settings.

Keepher 0 solutions 10 answers

I have Firefox v23.0.1. and did all of this. So far, nothing seems to address the issue. I disabled my anti-virus [Kaspersky Internet Security - 13.0.1 4190 (h) ] and the problem persists, so it is not likely to be culprit. I get the "cookies disabled" message on Kenexa/Brassring managed sites and unfortunately there is nothing on these sites to points to the site admin to see it there is problem on their end. I cannot be the only one with this issue...or can I?

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

Hi Keepher, if you allow all first and third party cookies without exceptions, and you have the same issue in Firefox's Safe Mode (where extensions are disabled), another thing to consider is whether sites are allowed to use local storage.

If you open a new tab and type or paste about:permissions in the address bar and press Enter, you should (after a brief delay) get a page showing various default permission settings. This is before you select a particular site. Check that your general setting for "Maintain Offline Storage" is not set to Block, and then look for the site where you are having this problem to see whether it has Block for this feature.

barry396 0 solutions 1 answers

I am having the same problem with the latest Firefox. Tried all suggestions and nada. Any other workaround?

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96698 answers

Make sure that your security software isn't blocking cookies if the settings in Firefox are OK.


If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.


Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

Keepher 0 solutions 10 answers

Seems nothing about this wants to fix the problem. I set first and third party cookies without exceptions, and you have the same issue in Firefox's Safe Mode. I check the "Maintenance Offline Storage" and it's set to "Always Ask." The sites I am having trouble with are not listed. I have already eliminated my Anti-Virus as a person of interest because it does the same thing when I disable it. There has got to be something I am missing here.

careyt39 0 solutions 11 answers

I really couldn't find any fix from the several replies received. Finally decided to use IE for awhile. One other thing was following the response above mentioning rebuild the cookies.sqlite file. That may have done the trick. Sorry about not being more precise, but had a number of irons in the fire.

Keepher 0 solutions 10 answers

Thank you for the help. I've tried everything I read but the cookies.sqlite above because I simply cannot find it. I found the page/screen and there were a number of files but "cookies.sqlite" was not among them so that was just another dead end. Something has been set wrong and darned if I can find it. I even disabled my security software altogether but problem persisted.

careyt39 0 solutions 11 answers

I'm in Windows 7 (your location may be different, if a different MS version), and the location where I found cookies.sqlite is: C:\<username>\AppData\Roaming\Mozilla\Firefox\Profiles

Made a copy and then deleted the original. Seems like I may have reinstalled FF, also. Appears to be fine now - and also I don't get the irritating instant crash as soon as FF is started after system startup.

Hope this helps.

Keepher 0 solutions 10 answers

Your response did in fact help in that your location info led me to my folder. I then discovered (quite by accident) that there is a link to it on the Firefox troubleshooting page. Anyway...it is official, I tried the "sqlite" solution, deleted all my cookies, cleared my cache, my history and rebooted....to my dismay, nothing changed. I still get "cookies disabled."

Actually it has changed a somewhat, the problem seems to have gotten worse as I am finding more https sites I used to get to are now blocking me out because of my "cookie" problem.

I have cleared and deleted everything I read to delete, re-set all of my preferences, removed any (albeit there were none) blocks and still remain a square one.

Thought this was a Kaspersky issue since it happened using IE and Firefox, but when I disabled it, I got the same result.

sigh.....I Just don't know where to go to now but am grateful for the help none the less.

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

Helpful Reply

Hi Keepher, does the problem only affect secure pages? That might be a clue that those connections are being handled differently somehow.

On the following non-secure test page, after the first load, if you reload, a cookie should appear in the "Full HTTP Request Headers" section (ASPSESSION... cookie). Is it there?

http://dev.jeffersonscher.com/jstest.asp

Keepher 0 solutions 10 answers

Thank you for helping. The problem only affects secure pages....so far anyway. On the initial load for the full http header it showed: "ASPSESSIONIDCQTBAASQ=HBPLGBGDLDKIPEPAPHBIDGDE" BTW...thought I posted this a few minutes ago...so if you get two replies, its just that my multitasking skills are stuck in the 3:30 PM mode.

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

Hi Keepher, there are a few steps in the process:

(1) Server sends cookies with the page
(2) Firefox stores the cookies
(3) Firefox sends the cookies with all subsequent requests

On #1, you can check whether the cookies are being sent all the way through to Firefox using the Web Console. Press Ctrl+Shift+k and then load the secure page. (This may take a while; it seems to bug down my Firefox today.) Click the request for the main page URL to pop up a list of the headers and cookies sent to and received from the server. Are you sending and receiving cookies?

On #2, you can view the cookies for a particular site using the Page Info dialog:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

On #3, see #1.

If Firefox is not receiving expected cookies, this could indicate that a proxy or filter or other intermediary is stripping them. If Firefox is sending cookies but the site is not receiving them, then similarly, they are getting lost in transit somehow. If Firefox is receiving but not storing cookies, this typically indicates a configuration issue in Firefox itself.