X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When I want to open a PDF document The box that pops up asking if I want to open or save does not come up and it always saves. I need this changed.

Posted

When the window opens to ask if I want to save or not comes up it does so for WORD documents just fine, however, for PDF documents it never asks (it used to). Now it just automatically saves them without asking. I need this changed. I went into applications and changed the setting to always ask but it still is just saving, them no window pops up asking what I want firefox to do with the file like it does with a WORD document. IF I cannot get this resolved I will not be able to continue using firefox. I teach and I have students submitting articles etc in pdf format, I cannot constantly save all pdf files. I just want to open them, review them and then move on. There must be a way to change this so that the window asking what I want firfox to do with the pdf files opens. thank you, kkwright

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Google Talk Plugin Video Accelerator version:0.1.44.24
  • Version 3.16.0.12200
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • 5.1.20125.0
  • Citrix Online App Detector Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • Picasa plugin
  • LogMeIn, Inc. Remote Access Components
  • ActiveTouch General Plugin Container Version 105
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • NPWLPG
  • CANON iMAGE GATEWAY Mycamera Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

alco 18 solutions 141 answers

Hi kkwright,

Firefox is able to display pdf files inside the the Firefox browser window, using the built-in PDF Viewer or a PDF reader plugin.
Have a look at this article:
View PDF files in Firefox without downloading them
Also, here is an addon doing the same: Pdf Viewer
Hope that helped you! Please report back!

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use the Adobe Reader or set to Always Ask in "Firefox > Options > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer and use the Adobe Reader instead.

Question owner

Thanks, I do have the applications box set to Always Ask. That is why it is so perplexing.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

Note that each entry in Tools > Options > Applications in tied to a specific MIME type (default application/pdf).
So you may have a rule for a different MIME type.

woehrling70 0 solutions 1 answers

This does not help. I want to open the pdf document in acrobat. Not in a web browser. I have selected the always ask option for all the acrobat applications listed in my firefox options, and still when I click on the hyperlink I get asked to save it. I don't want to save it I want to open it. This by the way is the hyperlink: http://www.redburn.com/RedburnCharts/130621_TechScored_Redburn_PRESS.pdf

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

Helpful Reply

Try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
KAUAIAN 0 solutions 3 answers

None of these options worked. I set it to ALWAYS ASK; nada. Set it to USE ADOBE 9.5; nada. Set it to OTHER and selected Adobe Acrobat; nada. As another reader said "it always used to." I also erased the mime types rdf file. :<0 Frustrated!

What changed?

Modified by KAUAIAN

KAUAIAN 0 solutions 3 answers

Same here. Seems I did an update lately and then POOF! No more ask to open. I want the files OPEN, not saved unles I save them.

jscher2000
  • Top 10 Contributor
2367 solutions 20957 answers

Hi KAUAIAN, in some cases you may have multiple and possibly conflicting PDF preferences. Renaming or deleting the mimeTypes.rdf file (see cor-el's reply above yours) can resolve that issue. Does it make any difference for you?

Modified by jscher2000

KAUAIAN 0 solutions 3 answers

Helpful Reply

Deleted it, restarted it. tried it again. no change. repeated the whole cycle. no change. thinking about uninstalling and reinstalling, but that won't reallyk change the settings.

Modified by KAUAIAN

jscher2000
  • Top 10 Contributor
2367 solutions 20957 answers

Hi KAUAIAN, thank you for the screen shot.

I think those first few preferences might be for fdf or x-fdf or other "forms related" types. If you hover your mouse over the left column entry, that may show in the tool tip.

In the search box on that tab, type pdf and then pause while the list is filtered. Hopefully this will surface the most relevant preferences.