X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Untrusted Connection = Suddenly firefox won't load Facebook! :(

Posted

facebook was working fine now suddenly I get this stuff about them not using a trusted security certificate and firefox won't open the site AT ALL! :(

SEE BELOW

This Connection is Untrusted



         You have asked Firefox to connect

securely to www.facebook.com, but we can't confirm that your connection is secure.

         Normally, when you try to connect securely,

sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.


         What Should I Do?
         
           If you usually connect to

this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.




       www.facebook.com uses an invalid security certificate.

The certificate is not trusted because no issuer chain was provided. The certificate is only valid for FF

(Error code: sec_error_unknown_issuer)

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Google Update
  • McAfee MSS+ NPAPI Plugin
  • SiteAdvisor
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Yahoo! activeX Plug-in Bridge

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Have you noticed problems with any other secure sites?

A few suggestions:

(1) Are you using any proxy services? You can bypass those here:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab, click the Settings button, then choose "No Proxy" and OK out.

Does that make any difference?

(2) You might also need to check your extensions, since they can change how Firefox accesses sites. Unfortunately, those were not listed along with your plugins.

You can use the following page to disable ALL nonessential, unrecognized, or unwanted extensions, then restart Firefox and see whether you can access Facebook.

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Any change?

(3) In case the problem is cached files, you can clear your cache.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

Cache

You can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

Cookies

You can open the dialog using:

Alt+t (opens the Tools menu) > Page Info > Security > "View Cookies"

In the filter box at the top, change the site to facebook.com

Then remove the cookies, OK out, and try reloading the page. Does that help?

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

Modified by cor-el

S1 5 solutions 54 answers

That means you been going to Facebook way to much! Let it cool off for a min. :)

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Helpful Reply

Check out why the site is untrusted (click "Technical Details to expand that section) and if this is caused by a missing intermediate certificate then see if you can install this intermediate certificate from another source.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer of the certificate.

You can see more Details like intermediate certificates that are used in the Details pane.

If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab".

Note that some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

-Nay- 0 solutions 2 answers

Helpful Reply

Good morning, I need help with this.

I have a similar problem, only it's worse.

Firefox doesn't load anything, and it is showing "Untrusted Security" for everything, even when I try to open its own "Add-on" tab.

I'm not sure if It happened after I re-installed Firefox, or after I reset Firefox to its default state.

I tried to clear the cache, and update the "Internet Time" but it's still not working.

Help, please.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Hi -Nay-, if you look at the "Technical Details" that the certificate is not trusted, does it provide any useful information?

What was the reason for using the Reset feature -- maybe this is related?

If this problem started only after the Reset:

I think Firefox starts with only its original certificates list after a Reset, so if your security software had installed a certificate into Firefox (for example, ESET software might do this) then you would need to re-trigger that process or import it manually. This is discussed in other threads, for example, I'm getting an error message "Untrusted Connection" on my on-line bankig site which I use all the time.

-Nay- 0 solutions 2 answers

Hi, I don't know why, but when I restarted the computer, the "Untrusted Connection" didn't appear anymore. (?)

Which is weird because there's no part in the installation that says it needs to be restarted.

But yes, answering your other question, Firefox was manifesting some issues before. I don't remember what it was, but I know that very slow loading was one of them.

Modified by -Nay-