X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Outdated Adobe Acrobat plugin

Posted

Hello, since today, before opening a pdf document, I reach a dark page where I have to click to activate the Adobe Acrobat plugin. I have Adobe PDF Plug-In For Firefox and Netscape 10.1.5 and I knew it was outdated because I check regularly the "check plugins" page, it used to be simply paired with the yellow button and that was all. Today I get black screens whenever I try to view pdf in Firefox and I have to click on them to view pdf. From the Add-ons/Plugins control panel I know see a warning red writing above the plugin entry stating "Adobe Acrobat is known to be vulnerable and should be updated". I cannot seem to update because I have Adobe Acrobat X pro, and I don't want to install the reader or purchase the newest version of the pro suite. My Pc runs with WIndows XP SP3 and is quite old, all other plugins are up to date, including Java and I don't want to use the new FF built-in pdf reader.

Any suggestion as how to disable the warnings and vulnerability screens or to update the plugin without installing Adobe Reader? Thank you

Chosen solution

hello, you can download the latest security update for acrobat 10.1.6 from http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • 5.1.20125.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Citrix Receiver Plugin (Win32)
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DjVu browser plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom)
  • ColorfulTabs 17.7 ({0545b830-f0aa-4d7e-8820-50a4629a56fe})
  • EPUBReader 1.4.2.1 ({5384767E-00D9-40E9-B72F-9CC39D655D6F})
  • FEBE 7.1.0 ({4BBDD651-70CF-4821-84F8-2B918CF89CA3})
  • Flagfox 4.2.7 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Form History Control 1.3.0.6 (formhistory@yahoo.com)
  • Ghostery 2.9.2 (firefox@ghostery.com)
  • Panic Button 1.5.1 ({24cea704-946d-11da-a72b-0800200c9a66})
  • Saved Password Editor 2.7 (savedpasswordeditor@daniel.dawson)
  • Tab Mix Plus 0.4.0.5 ({dc572301-7619-498c-a57d-39143191b318})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Web Developer 1.2.2 ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • Adblock Plus Pop-up Addon 0.7 (adblockpopups@jessehakanen.net) (Inactive)
  • Dictionary Tooltip 1.7 ({C6128004-4838-4708-9A97-BB172D17767D}) (Inactive)
  • DriverAgent Plugin for Firefox and Opera 2.2012.6.20 ({F8CC37C3-CBEB-4A00-8CBF-26A88693F0C5}) (Inactive)
  • Element Hiding Helper for Adblock Plus 1.2.3 (elemhidehelper@adblockplus.org) (Inactive)
  • Gmelius, Towards a Better Gmail™ 5.7.2 (gmailadsremover@florian.bersier) (Inactive)
  • HP Detect 1.0.19.2 ({ab91efd4-6975-4081-8552-1b3922ed79e2}) (Inactive)
  • iMacros for Firefox 7.6.0.2 ({81BF1D23-5F17-408D-AC6B-BD6DF7CAF670}) (Inactive)
  • LastPass 2.0.0 (support@lastpass.com) (Inactive)
  • Lazarus: Form Recovery 2.3 (lazarus@interclue.com) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • RememberPass 1.1.2 (rememberpass@teesoft.info) (Inactive)
  • SQLite Manager 0.7.7 (SQLiteManager@mrinalkant.blogspot.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon X1200 Series
  • adapterDescription2:
  • adapterDeviceID: 0x791f
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 2-10-2010
  • driverDate2:
  • driverVersion: 8.593.100.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.enable: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 640000
  • browser.cache.memory.enable: False
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: http://www.google.it/
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • browser.tabs.closeWindowWithLastTab: False
  • browser.tabs.selectOwnerOnClose: False
  • browser.tabs.warnOnClose: False
  • browser.zoom.full: False
  • dom.max_chrome_script_run_time: 60
  • dom.mozApps.used: True
  • dom.storage.enabled: False
  • extensions.lastAppVersion: 19.0.2
  • general.useragent.extra.betterprivacy:
  • javascript.options.strict: True
  • network.cookie.prefsMigrated: True
  • network.http.max-persistent-connections-per-server: 4
  • places.database.lastMaintenance: 1363254789
  • places.history.expiration.transient_current_max_pages: 23468
  • places.history.expiration.transient_optimal_database_size: 84818164
  • places.last_vacuum: 1298401666
  • plugin.disable_full_page_plugin_for_types: video/x-mpeg,video/mp4,video/x-ms-wmv
  • privacy.cpd.extensions-tabmix: False
  • privacy.donottrackheader.enabled: True
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 4
  • security.enable_java: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 10 Contributor
  • Moderator
2054 solutions 8922 answers

Chosen Solution

hello, you can download the latest security update for acrobat 10.1.6 from http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows

Question owner

I missed that, completely! Thank you very much!

MrsMoose2000 0 solutions 1 answers

Helpful Reply

The solution did not work for me. It had me download an msp file, but I do not have that software on my computer and do not want to download it. The description of msp on the internet sounds like downloading it will give more access to my computer than I want to give. I would appreciate clarification if I am being overly protective, but Mozilla Firefox, can you fix the problem so we can update from your button? Kindest regards, Robin

Question owner

Hello, the above solution worked for me because I have the software needed to install the msp update, and it was indeed the only solution for users of Adobe Acrobat Pro 10.1.5, which is a peculiar case. If you don't have any Adobe Acrobat software installed, you can simply download the Adobe Acrobat Reader http://get.adobe.com/reader/ which is free. Best!

Modified by Anisette

Hoosier33 0 solutions 1 answers

I am having the same problem with Adobe Acrobat 10.1.4 it keeps telling me "The upgrade patch can not be installed by Windows Installer service because the program to be updated may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be updated exists on your computer and that you have the correct upgrade patch." I have done this and it still will not work. I have used the update button on Firefox and it won't let me proceed with any update of this plugin. I have re installed the Adobe Acrobat X reader and it just tells me it is already installed, so that didn't help. Frustrated so please help.