X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get rid of Sweetpacks on tabs?

Posted

Sweetpacks installed itself without asking and I do not like it so how can I change back to Firefox on the tab pages?

Chosen solution

So glad to get rid of it! Thank you!

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • Picasa plugin
  • GEPlugin
  • Google Updater pluginhttp://pack.google.com/
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Shockwave Flash 9.0 r45

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

iamjayakumars
  • Top 10 Contributor
413 solutions 4905 answers

In order to uninstall a possibly unwanted extension, please do the following:

  1. From the Firefox window click the Firefox button at the top left and select Add-ons, or, if the Firefox button is not shown, click the Tools menu and click Add-ons.
  2. Once the Add-on Manager has opened in a new tab, click the Extensions button on the left side of the window.
  3. You should now see a list of your installed extensions on the right side together with buttons on the right side of each extension.
  4. To remove an extension from Firefox, simply click the Remove button. You should see a message that informs you about the successful removal of the add-on.
  5. Note that some add-ons require a Firefox restart to be removed completely. To perform a Firefox restart after the add-on removal, click the Restart now link in the message.

You can find further information about uninstalling extensions in the following articles:

Disable or remove Add-ons

Remove a toolbar that has taken over your Firefox search or home page

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Helpful Reply

Try to use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Solved, thanks. Clive Albert

Question owner

Solved thanks by another reply as follows iamjayakumars wrote: "In order to uninstall a possibly unwanted extension, please do the following:

  1. From the Firefox window click the Firefox button at the top left and select Add-ons, or, if the Firefox button is not shown, click the Tools menu and click Add-ons.
  2. Once the Add-on Manager has opened in a new tab, click the Extensions button on the left side of the window.
  3. You should now see a list of your installed extensions on the right side together with buttons on the right side of each extension.
  4. To remove an extension from Firefox, simply click the Remove button. You should see a message that informs you about the successful removal of the add-on.
  5. Note that some add-ons require a Firefox restart to be removed completely. To perform a Firefox restart after the add-on removal, click the Restart now link in the message.
Jeremy 1 solutions 8 answers

There is much more to just uninstall sweetpack toolbar from your browser, coz there are many other adware downloaded by this toolbar. You can get more about this sweetpacks thing at

Modified by James

harveyg 0 solutions 1 answers

CliveAlbert's suggestion to use: https://addons.mozilla.org/firefox/addon/searchreset/ worked for me. i had the sweetpacks removed from everywhere including addons. but it still showed when i opened a new tab. the search reset add on worked perfectly. thank you!!

Neilfox 3 solutions 42 answers

I thought this might be useful too:

http://deletemalware.blogspot.com/2013/04/how-to-remove-start-sweetpacks-and.html

Sweetpacks usually comes bundled with adware, so I think it would be a good idea to scan your computer with AdwCleaner and Malwarebytes.

http://www.bleepingcomputer.com/download/adwcleaner/

bradmor 0 solutions 1 answers

So far sweetpacks will not go away. I have disabled it in add-ons on both Fox and IE. I have reset Fox. I'm going to do one more restart after all this then guess i will go pay someone to remove it. Thanks to everyone who thought they could help.

Modified by bradmor

LunaSerenity13 1 solutions 1 answers

Chosen Solution

So glad to get rid of it! Thank you!

silverbec 0 solutions 5 answers

Helpful Reply

I fought with this and did everything I can think of - malware removal tools, uninstaller tools, everything. But none of them stopped Sweetpacks from taking over a new tab (got it by accident from a piece of freeware). Removing it is startlingly simple, and I wish Mozilla would provide an option to set this without having to go into the config:

How to Remove Sweetpacks New Tab for FireFox 1. In the address bar, type 'about:config' and then click Enter. 2. You will be notified that you are about to change your settings. Click 'I'll be careful, I promise!' 3. You will see a Search field, type ‘newtab' and then click 'browser.newtab.url'. 4. In the box that will be opened, enter the URL that you want to open in the new tab page instead of Sweetpacks and then click OK. (I chose to leave that blank, because I need a clean window.)

Worked for me. Hopefully I've eliminated all the cookies and other bits, but now I know how to clear it out if it comes back again.