X
Tap here to go to the mobile version of the site.

Support Forum

"New" option in "Save As" context menu is frequently wrong

Posted

When using the right click context menu on the Save As window (from either File/Save File As, or when downloading a file from a web page), the "New" item in the context menu sometimes works correctly by showing the correct sub menu, but very frequently will open a sub menu with only the word "New". Clicking on the sub menu "New" opens the Create Shortcut Wizard window.

Pictures - I get this: http://img.photobucket.com/albums/v250/JeffLeites/MyWebPhotos/ScreenHunter_02Mar162027.jpg

Instead of this: http://img.photobucket.com/albums/v250/JeffLeites/MyWebPhotos/ScreenHunter_01Mar162026.jpg

This happens on both my desktop and notebook. It ONLY happens in FireFox, all other programs perform correctly.

I've searched the web for this problem, and only found two other inquiries about it (no solution), so I am not the only one with this problem. Example - http://superuser.com/questions/432688/firefox-xp-sp3-save-as-context-menu-broken

When using the right click context menu on the Save As window (from either File/Save File As, or when downloading a file from a web page), the "New" item in the context menu sometimes works correctly by showing the correct sub menu, but very frequently will open a sub menu with only the word "New". Clicking on the sub menu "New" opens the Create Shortcut Wizard window. Pictures - I get this: http://img.photobucket.com/albums/v250/JeffLeites/MyWebPhotos/ScreenHunter_02Mar162027.jpg Instead of this: http://img.photobucket.com/albums/v250/JeffLeites/MyWebPhotos/ScreenHunter_01Mar162026.jpg This happens on both my desktop and notebook. It ONLY happens in FireFox, all other programs perform correctly. I've searched the web for this problem, and only found two other inquiries about it (no solution), so I am not the only one with this problem. Example - http://superuser.com/questions/432688/firefox-xp-sp3-save-as-context-menu-broken

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Talk Plugin Video Accelerator version:0.1.44.24
  • Version 3.15.2.12038
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.4"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Citrix ICA Client Plugin (Win32)
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Extensions

  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b})
  • Norton Vulnerability Protection 11.1.1.5 - 3 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • ShareMeNot 2.2 (sharemenot@franziroesner.com)
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 8400M GS
  • adapterDescription2:
  • adapterDeviceID: 0x0427
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'257.21']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 5-11-2007
  • driverDate2:
  • driverVersion: 6.14.11.128
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'257.21']
  • numTotalWindows: 2
  • webglRendererMessage: [u'tryNewerDriver', u'257.21']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.link.open_newwindow: 2
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.startup.homepage: http://my.yahoo.com/
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • browser.tabs.onTop: False
  • browser.zoom.full: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • gfx.blacklist.suggested-driver-version: 257.21
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1362971012
  • places.history.expiration.transient_current_max_pages: 100614
  • places.history.expiration.transient_optimal_database_size: 42870538
  • places.last_vacuum: 1294432036
  • plugin.disable_full_page_plugin_for_types: audio/mpeg,audio/x-mpeg,application/pdf
  • privacy.cpd.cookies: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars 475 solutions 5840 answers

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

'''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.''
cor-el
  • Top 10 Contributor
  • Moderator
12137 solutions 112749 answers

Try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions.

Try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions. *http://kb.mozillazine.org/mimeTypes.rdf *http://kb.mozillazine.org/File_types_and_download_actions#Resetting_download_actions

Question owner

I've already tried FF in Firefox Save Mode. I also tried creating a new profile. Neither made a difference. I asked a friend to try it on his computer (XP) and he got the same random results as me. I can't find mimType.rdf file to delete, but I doubt it would help since trying a new profile didn't help.

BTW, I made an unlisted video demo of the problem here: http://www.youtube.com/watch?v=znbxtdBO7LE

I've already tried FF in Firefox Save Mode. I also tried creating a new profile. Neither made a difference. I asked a friend to try it on his computer (XP) and he got the same random results as me. I can't find mimType.rdf file to delete, but I doubt it would help since trying a new profile didn't help. BTW, I made an unlisted video demo of the problem here: http://www.youtube.com/watch?v=znbxtdBO7LE