Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In the last few days, Firefox 3.6.28 automatically launches when I start my iMac (OSX v 10.4.11); what happened?

  • 8 replies
  • 4 have this problem
  • 868 views
  • Last reply by editproofm

more options

I tried going to System Preferences/Accounts/Login Items, and Firefox is not checked "On" there. Then I tried changing my default browser to Safari instead of Firefox, but Firefox again launched automatically on startup! I have not added any new bookmarks. No one but me touches my computer, so nobody else could have changed a setting.

All Replies (8)

more options

Is Firefox the default browser?

Does it make a difference if you set another browser as the default browser?

more options

Firefox is my default browser... but I have tried changing it to Safari temporarily. It made no difference: Firefox still automatically launched when I turned on the computer. This issue just started a few days ago, for no apparent reason. I am stumped as to cause and solution! I will be grateful to anyone who can figure this one out.

more options

You can try to uninstall (trash) Firefox and reinstall Firefox.

Firefox 3.6.28:

more options
more options

Thanks, but I already tried that too. See the "Details" from my original query, copied below:

I tried going to System Preferences/Accounts/Login Items, and Firefox is not checked "On" there. Then I tried changing my default browser to Safari instead of Firefox, but Firefox again launched automatically on startup! I have not added any new bookmarks. No one but me touches my computer, so nobody else could have changed a setting.

I have also un-checked the automatic RSS feed box, but still no solution... Am waiting to uninstall/reinstall Firefox (suggestion from earlier respondent) as a last-resort fix, but that might be what must happen...

Modified by editproofm

more options

Do you have it bundled with TOR Browser ?

more options

No, I don't use Tor Browser.

more options

Good morning, everyone. News flash: I inadvertently solved my own problem... not through technical skill or intelligence, but by noticing something that I never noticed before. In case anybody else has this issue in the future, the solution is found on the Firefox icon in the dock at bottom of my screen. I was holding down the mouse on the Firefox dock icon, in order to quit Firefox, and when the pop-up menu appeared I noticed an option "Open at Login," which was checked. So, I unchecked it, and that was that! (Somehow I must have accidentally checked it at some point.) Note that this pop-up menu is connected to the dock icon at bottom of the screen, and did not appear on the menu bar at top of screen. In any event, I do want to thank you all for the time you spent on this issue. But mostly, I am thrilled that there's nothing wrong with my operating system and I won't have to reinstall any applications. Thanks!