X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can I disable pdf.js for all users?

Posted

We as a company deal with a lot of PDF files.. Now while we can simply download the PDFs and there not be a problem, we're used to the Adobe Viewer and *not* downloading them.

I've been told the new pdf.js viewer will not display most of the PDFs we throw at it on a day to day basis.

Although there is a way to disable pdf.js (about:config), this only seems to change for the local user. We have FF 19 installed on terminal servers, and would like to know if there is a way to disable it for all users?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • 5.1.10411.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • LEADTOOLS CMP Plugin DLL

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • British English Dictionary 1.19.1 (en-GB@dictionaries.addons.mozilla.org)
  • Firebug 1.11.2 (firebug@software.joehewitt.com)
  • Lazarus: Form Recovery 2.3 (lazarus@interclue.com)
  • Multi Links 3.0.0.19 (multilinks@plugin)
  • QuickJava 1.8.0 ({E6C1199F-E687-42da-8C24-E7770CC3AE66})
  • Symantec Intrusion Prevention 11.3.0.9 - 3 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • Tab Mix Plus 0.4.0.5 ({dc572301-7619-498c-a57d-39143191b318})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Web Developer 1.2.2 ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • Case Changer 2.0.0.18 (casechanger@plugin) (Inactive)
  • Clippings 3.2 ({91aa5abe-9de4-4347-b7b5-322c38dd9271}) (Inactive)
  • FEBE 7.1.0 ({4BBDD651-70CF-4821-84F8-2B918CF89CA3}) (Inactive)
  • Flashblock 1.5.15.1 ({3d7eb24f-2740-49df-8937-200b1cc08f8a}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: RDPDD Chained DD
  • adapterDescription2:
  • adapterDeviceID: 0x0000
  • adapterDeviceID2:
  • adapterDrivers: RDPDD
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x0000
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedGfxCard']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate:
  • driverDate2:
  • driverVersion:
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedGfxCard']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.check_doc_frequency: 1
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.enable: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 716800
  • browser.cache.memory.enable: False
  • browser.link.open_newwindow: 2
  • browser.link.open_newwindow.restriction: 0
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.sessionstore.max_tabs_undo: 40
  • browser.startup.homepage: http://www.google.co.uk/
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • dom.ipc.plugins.enabled.npietab2.dll: True
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0
  • font.internaluseonly.changed: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1362561172
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • plugin.disable_full_page_plugin_for_types:
  • privacy.sanitize.migrateFx3Prefs: True
  • security.enable_java: False
  • security.warn_viewing_mixed: False
  • security.warn_viewing_mixed.show_once: False

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

Helpful Reply

hello, can you try it with the method described at http://kb.mozillazine.org/Locking_preferences?

JasonNVSD 0 solutions 6 answers

I have the same issue. I've gone through all the preferences I could find in about:config and none of them will set it back to Adobe Reader.

Question owner

Like Jason, I'm still having the issue.

Although, locking preferences *did* work but instead defaulted to saving PDFs automatically as opposed to viewing them in the Adobe Reader plugin.

Is there another config setting I can change/lock for the Adobe Reader plugin to load instead?

JasonNVSD 0 solutions 6 answers

Hey jevison,

At first I tried setting pdfjs.disabled, and like you mentioned, it would download PDFs instead of opening them in the Reader plugin.

What worked much better was clearing plugin.disable_full_page_plugin_for_types. When upgrading to FF19+, it adds "application/pdf". Obviously if there are other values in there, or other values need to be added later, locking it empty will break that. I'm trying to find out if (a) you can parse and edit a value instead of merely setting it or (b) whether there should ever be other values in there.

If you find an answer to either of those, make sure to post it here.