X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox is not allowing pop ups after latest update, despite un-checking the "block pop-up windows" under tools/options

Posted

Yesterday when i booted up my computer and opened firefox, I noticed that I couldn't open the player for my siriusXm radio subscription. If I open google chrome, it works just fine. Same goes for a website that I must access for my work. When I hit a button, typically a pdf file opens up. It does NOTHING. This is incredibly frustrating, and going into the tools>options>content and un-checking the box for pop ups produces no change even after re-starting my computer. Please advise ASAP or I will be forced to drop firefox and go back to explorer or chrome. This isn't something I want to do, as I have all of my favorites marked, tabs pre-set, etc.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • np-mswmp
  • Conduit Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • Picasa plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

If this is a problem with PDF files not working then try to disable the integrated PDF viewer.

Current Firefox versions have enabled a new build-in PDF Viewer that doesn't have all the features that other PDF readers like the Adobe Reader have.

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use the Adobe Reader or set to Always Ask in "Firefox > Options > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

See also:


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.