X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why do FF menu entries turn black when I mouse over them?

Posted

FF19, Win 7 w/updates, ATI Radeon 5750 w/latest Catalyst drivers.

FF menus initially display correctly with black text on a white background. When I mouse over the text, enabled menu entries turn to black text on a black background. The active menu entry is displayed correctly but when the mouse leaves it, the entry stays black until the mouse leaves the menu, then the entire menu reverts to a correct display. Greyed out menu entries show as grey text on a black background.

The h/w acceleration option doesn't seem to affect the problem.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • npsitesafety
  • iTunes Detector Plug-in
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • npFFApi
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Garmin Communicator Plug-In 4.0.4.0
  • 4.1.10329.0
  • Picasa plugin
  • GEPlugin
  • BitCometAgent v1.27 for Firefox
  • Logitech Device Detection
  • vivoxvoiceplugin
  • getplusplusadobe16291
  • Garmin Communicator Plug-In 2.9.2.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/en-US/

Extensions

  • Collusion 0.25 (jid1-F9UJ2thwoAm5gQ@jetpack)
  • ColorfulTabs 17.6 ({0545b830-f0aa-4d7e-8820-50a4629a56fe})
  • Dictionnaires français 4.9 (fr-dicollecte@dictionaries.addons.mozilla.org)
  • Download Statusbar 0.9.10 ({D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389})
  • FlashGot 1.5.4.2 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • FoxTab 1.4.9 ({ef4e370e-d9f0-4e00-b93e-a4f274cfdd5a})
  • Garmin Communicator 4.0.4 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Logitech Device Detection 1.23.0.5 (DeviceDetection@logitech.com)
  • Personas 1.6.2 (personas@christopher.beard)
  • Pocket 3.0.1 (isreaditlater@ideashower.com)
  • SearchPreview 6.1 ({EF522540-89F5-46b9-B6FE-1829E2B572C6})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Vivox Voice Plugin 1.18.3.4133 ({ABAD4342-3FDA-4ccf-80AC-B6D0EECACA07})
  • zonealarm.com 1.6.0 (ffxtlbr@zonealarm.com)
  • AVG Security Toolbar 14.2.0.1 (avg@toolbar) (Inactive)
  • BitComet Video Downloader 1.29 ({B042753D-F57E-4e8e-A01B-7379A6D4CEFB}) (Inactive)
  • Conduit Engine 3.3.3.2 (engine@conduit.com) (Inactive)
  • Cooliris 1.12.3.58254 (piclens@cooliris.com) (Inactive)
  • Delicious Bookmarks 2.3.1 ({2fa4ed95-0317-4c6a-a74c-5f3e3912c1f9}) (Inactive)
  • HP Smart Web Printing 4.60 (smartwebprinting@hp.com) (Inactive)
  • Skype Click to Call 6.6.0.11664 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)
  • ZoneAlarm Security Engine 1.5.393.22 ({FFB96CC1-7EB3-449D-B827-DB661701C6BB}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 5700 Series
  • adapterDescription2:
  • adapterDeviceID: 0x68be
  • adapterDeviceID2:
  • adapterDrivers: aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 400
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-19-2012
  • driverDate2:
  • driverVersion: 9.12.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 5700 Series)
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.google.com/ig
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • browser.tabs.loadInBackground: False
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • dom.ipc.plugins.enabled.npcoolirisplugin.dll: False
  • dom.max_script_run_time: 1800
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0
  • general.useragent.extra.zencast: Creative ZENcast v2.01.01
  • javascript.enabled: False
  • keyword.URL: http://search.avg.com/route/?d=4cb99dc1&v=7.008.031.001&i=23&tp=ab&iy=&ychte=nl&lng=en-US&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1362082408
  • places.history.expiration.transient_current_max_pages: 93834
  • places.history.expiration.transient_optimal_database_size: 150133144
  • places.last_vacuum: 1302141856
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.disable_button.openCertManager: False
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No
finitarry 157 solutions 2175 answers

Are you using the default theme or a third party theme? If you use only the default theme, you could put some code into a userChrome.css file in a chrome subdirectory in Firefox's profile. I think this should do:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); 

menu:hover,
menuitem:hover{
  background: #FFFF80;
  color: #000;
}

menu[disabled="true"],
menuitem[disabled="true"],
menu[_moz-menuactive="true"][disabled="true"],
menuitem[_moz-menuactive="true"][disabled="true"] {
  color: #808080;
  background: #FFF;
}

You can change the colours to suit you.

http://kb.mozillazine.org/UserChrome.css

Modified by finitarry

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Helpful Reply

Try to disable hardware acceleration in Firefox.

Question owner

cor-el,

Thanks for the suggestion, but please read the original post a little more carefully. I did mention that this doesn't solve the problem. Sorry.

Modified by djmast

Question owner

Finitarry,

Nice try. I reverted to the default theme and tried other random themes but the behaviour doesn't change.

I implemented the code you suggested, shut down and restared FF, and the only effect it seemed to have is that alternate menus display in the menu bar colour instead of black. Submenus perform the same as their parent menus. Otherwise, same behaviour. How do I know the code actually being executed?

Another symptom that I just noticed, possibly unrelated, is that I cannot select a Persona from the Tools menu. I can navigate to the menu entry but when I move my mouse over a Persona, FF flashes the Persona, as if previewing, reverts to the current one and closes the menus. I can't actually select a Persona from any of the Persona sub-menus other than default.

Modified by djmast

finitarry 157 solutions 2175 answers

Could it be a corrupt localstore.rdf file in the profile?

Question owner

finitarry,

Nope. Followed the instructions and there was no appreciable effect. Some menus didn't change to back but the menu item selection highlighting stayed active on every menu item I moused over. Other menus still turned black.

Gone back to the original localstore.rdf.

mgwern 0 solutions 1 answers

Helpful Reply

Having the same problem with Win7 and switchable Intel HD 4000/Radeon HD 7670M. I had Firefox set to high performance in Catalyst Control Centre. Changing this to power saving solves the problem for me. However, this is not an ideal solution because full-screen video (BBC iPlayer/YouTube) is less good as a result. This is my first contribution here and I'm just hoping it provides a useful clue as to what's happening.

Question owner

finitarry,

Sorry for the long delay. The instructions you posted have taken me a while to go through.

1. Firefox restarted many times and doesn’t solve the problem 2. I don’t see how history and cookies could cause this, but done anyway. No change. BTW I changed the theme but it was also without any joy. 3. Started in Safe Mode. Same behaviour. 4. If the behaviour appears in Safe Mode, then the plug-ins aren’t the problem. However, I updated the ones FF said were old. No affect. 5. I'll leave resetting and reinstalling until all other avenues are exhausted but this might be the only remaining approach.

I thought that the problem must be with the video card/drivers although I have the latest ones from ATI. I've changed the resolution and refresh rate, altered the performance, 3D and AA settings but still can't alter FF's behaviour.

Thanks for trying.