X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 19 preferences does not show cookies

Posted

In the privacy settings I have checked the box to accept cookies, but box to accept cookies from 3rd party sites is unchecked. Further setting are "use custom setting for history" and "tell websites not to track. Up until a few days ago, if I clicked show cookies it listed all the cookies of sites I had visited and I could remove them individually. All of a sudden Firefox (19) does not show any cookies in the box anymore. I have not changed any of the settings. How can I ensure to the see the cookies listed again?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • iPhoto6
  • Picasa plugin.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Firefox > Preferences > Privacy: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"
beaobi 0 solutions 1 answers

Helpful Reply

My private settings are exactly like the OP's , and I'm experiencing the same problem.

I do not have Firefox 19 set on permanent Private Browsing mode, but I do use it occasionally. I notice this in fact only happens when using private browsing.

Is the only option/solution to stop using Private Browsing mode completely??

lastontheboat 0 solutions 1 answers

Yes, there is currently no way to modify/view private cookies (ie. all cookies in private browsing mode in FF 19, or cookies for private windows in FF 20+). Your only option is to reopen private browsing mode to clear the accumulated cookies.

csniffer 0 solutions 1 answers

I have the same problem. So when I surf in normal mode to website the browser has X cookies. When I repeat that after switching to private browsing mode the browser only show < X cookies

pginsburg 0 solutions 1 answers

Helpful Reply

I just entered this comment in Feedback. Are there others who think this is a good idea?

I have used Firefox for many years, and I've always been grateful for the superb work on a wonderful browser that is done in a great spirit of generosity by what must be a huge number of very good, very smart people. And in all those years, there has been one -- and only one -- persistent problem, cookies. The most recent change, which took away the list from "Show cookies" is an annoyance (and I see that there are at least 54 others who feel the same way) that only highlights the basic defect of cookie-handling: For those of us who prefer to allow cookies only when they are required by a site we want to visit (and again, I see from the questions and comments in "Help" that I'm not the only one who does this and yes, I know I can allow them selectively for sites I visit regularly, but often one arrives at a new site or wants to complete a transaction and gets stymied by the cookie requirement), the process of opening and closing the door has always been a multi-step pain in the neck. May I suggest that you put a button (that looks like a chocolate-chip cookie, my favorite) somewhere on the menu or navigation toolbar that would allow cookies when clicked the first time and cut them off while removing all cookies when clicked the second time?