X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get firefox to open a pdf in adobe instead of the new pdf reader?

Posted

Before the recent update, 19.0, I would google something and see [PDF] next to a link. I click the middle mouse button to open it in a new tab. Firefox would download the file and open it with Adobe Reader. I like this.

With the new update 19.0, the pdf file would be opened in the new tab. I have to go and down load it and then open it in Adobe. I don't like this.

I go into preferences under applications. I look to see if I can change this. Next to Adobe Reader document, I choose Use Adobe Reader, but when I click on a [PDF] link, it still opens the file in Firefox and not Adobe.

I want it back to the way it was.

Chosen solution

Problem: Open a pdf in Firefox, it wants to save the file. Remedy: In Firefox, Tools, Options, choose Applications tab. Left (Content Type) column, choose Portable Document Format (pdf). Right column (Action) choose Preview in Firefox. I am using Firefox 21.0. Wednesday, May 29, 2013, Tom Budlong

Read this answer in context 15

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Juniper Networks Safari Extensions
  • Enables the interaction of Mathematica content with the latest installed version of Mathematica.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96833 answers

Helpful Reply

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer and use the Adobe Reader instead.

See also:

StevieTNZ 0 solutions 9 answers

I changed the setting to true, but now it asks me to save the PDF rather than open it in Adobe Reader within FF.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96833 answers

Check the settings for PDF files.

  • Firefox > Preferences > Applications > Adobe PDF document : Use Adobe Reader
wpdster 0 solutions 5 answers

I see the same behavior -- I changed the pdfjs.disabled setting to true and now Firefox asks me to save (most) PDF files without giving me the option to open them directly with Acrobat Reader. I followed the link given above and verified that Adobe Acrobat PDF document is set to "Always ask". I don't understand why Firefox doesn't give me the option to open the files in Acrobat Reader. Nor do I understand why this is true for most, but not all pdf files (such as http://www.ti.com/lit/gpn/am26c31; I can't find an example of one that works outside our internal web site, which might be a clue that our internal web site is not configured properly).

I hate it when arbitrary changes to software breaks my workflow. http://xkcd.com/1172/

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96833 answers

Do you have the Adobe Reader plugin installed and enabled?

  • Tools > Add-ons > Plugins
wpdster 0 solutions 5 answers

I don't have the plugin enabled. Traditionally, that was the only way I could figure out how to tell Firefox that I wanted to read PDF documents with the standalone reader instead of in a separate window/tab within Firefox.

The plugin I have is "Adobe Acrobat NPAPI Plug-in, Version 10.1.6". Is that the latest/best plugin to use? All I want is for Firefox to ask me "Save, or open with Reader" when I download PDFs. I don't want to view them within Firefox.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96833 answers

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can change the action for Portable Document Format (PDF) from Preview in Firefox to Always Ask in "Firefox > Options > Applications".

See also:

wpdster 0 solutions 5 answers

Hi cor-el, Thank you for your reply.

I have pdfjs.disabled pref set to true.

I have set the following Content Types to "Always ask":

  • Adobe Acrobat FDF document
  • Adobe Acrobat XML Data Package File
  • Adobe Form Client Data File
  • Portable Document Format (pdf/adobe)
  • Portable Document Format (doesn/matter)
  • Portable Document Format (binary/octet-stream)
  • Portable Document Format (application/x-pdf)
  • Portable Document Format (application/x-octet-stream)
  • Portable Document Format (application/x-download)
  • Portable Document Format (application/force-download)
  • Portable Document Format ("application/pdf")

And I just noticed now that Portable Document Format (application/pdf) is set to "Adobe Reader"

With the release of 19.0, Firefox started displaying PDF documents within Firefox itself, which I don't want. I found a page that directed me to set pdfjs.disabled to true, which I have done, and now Firefox only offers me the option of saving PDF documents -- it no longer offers me the option of displaying them with Adobe Reader.

I would like to know how to make Firefox go back to the old behavior of asking me whether I wanted to save the document, or open it with Adobe Reader. So far, I can't figure out how to do that.

Thanks again for the tips. Please keep them coming.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96833 answers

Do you have an enabled Adobe Reader plugin on the Tools > Add-ons > Plugins page?

Yo you set the action for Portable Document Format to Adobe Reader (in Firefox)?

Maybe best to remove these actions and only leave application/x-pdf

  1. Portable Document Format (doesn/matter)
  2. Portable Document Format (binary/octet-stream)
  3. Portable Document Format (application/x-octet-stream)
  4. Portable Document Format (application/x-download)
  5. Portable Document Format (application/force-download)
wpdster 0 solutions 5 answers

Hello again cor-el, and thank you so much for your patience and willingness to help.

I do not have an enabled Adobe Reader plugin. My understanding of such plugins is that they allow one to read PDF documents from within Firefox. I don't want that capability. I would like Firefox to ask me each time I download a PDF "Do you want to save this document or do you want to open it with Adobe Reader?"

Currently (since I set pdfjs.disabled to true) Firefox only asks me where I want to save the document.

I'm not sure how to remove the actions you suggest I remove. There doesn't appear to be any sort of "Delete" button or icon next to any of the document types.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96833 answers

If the Adobe Reader program is set as the default application for PDF files on your computer (right-click a saved PDF file in Windows Explorer and use Open or open with) then Firefox should offer this program as the first choice for an application when you get the Open with and save dialog.

You can also temporarily set a default automatic action to use the Adobe Reader program and change that afterward to Always Ask in Options > Applications.

Rhlsg 0 solutions 6 answers

I do not have "Adobe PDF Document" or any entries named "Portable Document Format" under Options > Options > Applications. How can I get that back and then set it to open inside FF using Foxit plugin ? thanks

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96833 answers

You can delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
Rhlsg 0 solutions 6 answers

Thanks cor-el, I did delete the mimetypes file after exiting FF but that did not get back the PDF entry. I got back "Portable Document Format" entry back after turning the pdfjs.disabled to false again. now trying to make PDFs read inside FF using Foxit and not Adobe.

Rhlsg 0 solutions 6 answers

https://support.mozilla.org/en-US/questions/950992#answer-440177

If anyone has the same problem, see how I resolved it, hoping it could help others too.

budlong 1 solutions 3 answers

Chosen Solution

Problem: Open a pdf in Firefox, it wants to save the file. Remedy: In Firefox, Tools, Options, choose Applications tab. Left (Content Type) column, choose Portable Document Format (pdf). Right column (Action) choose Preview in Firefox. I am using Firefox 21.0. Wednesday, May 29, 2013, Tom Budlong

jefmafnl 0 solutions 1 answers

I have the same problem (pdf files not automatically opening in Adobe), under Mac OS X 10.7. There is no Tools/Options, but there is an Applications box under Firefox/Preferences.

Content type "Adobe Acrobat FDF [sic] document" is matched with Adobe Reader as a default. Does this misprint have consequences? If so, how do I add "Adobe Acrobat PDF document"?

Thanks.

jefmafnl

fofcom 0 solutions 6 answers

Same problem for me. I am using FireFox V22. I have pdfs created with Adobe Presenter 8.0 that appear for presentation as pdf documents (pdf version 1.7 Acrobat 9.x). These file must open in Reader or Acrobat. My links are in Moodle to the pdf. No matter how I set the attributes in FireFox or in Moodle, the FireFox Pdf viewer trys to open them. I can't read them or display them, so you have to then click the "use other viewer" option, which presents the pdf reader. But this really looks unprofessional. Of course, the same problem occurs in Chrome, so no help there. Would be great if a solution could be found.

Regards, Rod