X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Foxfire 18.0.2 will not open on my homepage, although I had set and reset the homepage, also when I close a page with tabs, they come back the next time I open

Posted

Foxfire 18.0.2 will not open on my homepage. When it does open, it opens with all the tabs and pages I had open in the last session, even if I have shut the computer down. If my homepage is there it is the version I had in the last session-not updated.

I reset the homepage, several times, and cleared the history, set it not to remember history. Nothing helps. What do I do now? I am tired of this and need it to stop so help please..

Modified by Noah_SUMO

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • 4.1.10329.0
  • A component of your photo software powered by RocketLife
  • NPWLPG
  • Zeon PDF Plugin For Mozilla
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

You can set Firefox to resume your previous session automatically. Please check the following in case that got switched on somehow:

orange Firefox button or classic Tools menu > Options > General

"When Firefox starts" setting.

If you reset this to "Show my home page" and it flips back when you close and restart Firefox, please see the following article: How to fix preferences that won't save.


A less likely possibility is that Firefox isn't really shutting down all the way, so when you restart it you're actually in the same session. After closing Firefox, you can check the Windows Task Manager to see whether there are any active windows that are not visible on screen.

Please allow 20-30 seconds for Firefox to shut down normally, then launch the Task Manager using Ctrl+Shift+Esc (you might need administrator permissions for this)

On the Applications tab, check for any Firefox icons.

On the Processes tab, check for firefox.exe (you can alphabetize the list by clicking the "Image name" column heading).

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

One other idea: Firefox will automatically resume your last session if it thinks it crashed. You can stop Firefox from doing this if you like.

To prevent Firefox from automatically resuming your last session after a crash, you can change a setting as follows.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste resume and pause while the list is filtered

(3) Double-click browser.sessionstore.max_resumed_crashes and set the value to 0. You're done in about:config.

After future crashes, when you restart Firefox, it should present you with a list of the windows and tabs you had open during your previous session so you can choose which, if any, to restore.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You can also check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

Question owner

It was set on Show My Homepage sand has never been set on another setting. This didn't work

Question owner

I tried all of these and none of them worked, there does not appear to a place in Foxfire 18, options to restore a session. I could not find it and there is no preferences tab as the article says . I believe that must have been an older version. THANK YOU FOR TRYING.

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Hi olou59dene, there is no Preferences tab in a dialog box, but you can edit preferences using the about:config interface as noted above.

Question owner

I found 4 preferences but I do not know what to change. Do you think it would work if I deleted Foxfire and downloaded it again? Would I lose my favorites?

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

If you uninstall Firefox, you have the choice to keep or remove your personal settings, such as bookmarks.

Could you try creating a new Firefox profile? This would be parallel to your current personal settings and you could easily switch back.

With Firefox closed, use the search box on the Windows Start menu to run this:

firefox.exe -p

More info: Use the Profile Manager to create and remove Firefox profiles. Note: I recommend not deleting any profiles until you are 110% sure you won't need the data in them.

Create a new profile with the default settings; you can name it TEST if you like.

The new profile will have your plugins (e.g., Flash, Adobe Reader) but otherwise will look like a new installation of Firefox. When you exit and restart Firefox, it stays in the last used profile until you go back to the Profile Manager to start up in a different one.

Does the new profile work any better?