X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

youtube doesnt go complete fullscreen in Mac OS X mountail lion.

Posted

When i try to go fullscreen for youtube videos, its trying to use Mountain lion's fullscreen feature instead of flash fullscreen, this make my videos stutter and looks really bad

Additional System Details

Installed Plug-ins

  • Version 3.13.2.11592
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Shockwave Flash 11.5 r502
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.5
  • Simple plug-in that handles Citrix connection files
  • iPhoto6
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • F5 Network Access plugin, Ver. 7070.2012.1026.1
  • 5.1.10411.0
  • Facebook Video Calling by Skype
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.0.55
  • Octoshape Streaming Services web integration browser plug-in
  • Picasa plugin.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9
  • Microsoft Office for Mac SharePoint Browser Plug-in

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3023 answers

Helpful Reply

Could you try disabling graphics hardware acceleration? Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!