X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 18.0.2 crashes when I try to check if my plugins are up-to-date from a standard user account

Posted

If I open Firefox 18.0.2 using an administrator account, the plugin check works with no problems. However when I try to check them from a standard user account, it just hangs and has to be closed using Task Manager. The check page opens, but no plugins are listed, and then it freezes.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • npsitesafety
  • Foxit Reader Plug-In For Firefox and Netscape
  • Nokia Suite Enabler Plugin
  • VLC media player Web Plugin 2.0.2
  • NPWLPG
  • 5.1.10411.0
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • DivX VOD Helper Plug-in
  • IE Tab Plug-in for Mozilla/Firefox
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Helpful Reply

I ran a deep scan for rootkits, I ran a microsoft system file check, I ran a full system scan in safe mode using AVG Antivirus, and I ran a full scan with Malwarebytes, again in safe mode. I also downloaded on another machine a copy of the AVG rescue dusk, and used that to run a full scan. None found anything dubious or suspicious. So thanks for the suggestion, but I can't see it being a problem with malware. Anyone have any other ideas?

Question owner

Just a further update. I tried leaving the plugin check running whilst I went away and did something else. When I returned, there was an error message saying that a script wasn't working. I pressed continue, and a few moments later, it came back again. I pressed enter again, and then it went through at normal speed and worked properly. So I guess it's a scripting problem?

Helpful Reply

It would appear that this problem was caused by my disabling Java as we have been recommended to do for security reasons. I updated to the latest version of Java, and re-enabled it, and the plugin checker now works fine. Could someone please confirm that this would cause the problem I have been seeing? Thanks.