X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Java 7 update 13 not recognized by Firefox 18.0.2

Posted

I recently updated my java to version 7 update 13 and FF 18.0.2. Somewhere in between, Firefox no loner recognizes Java. I've tried removing Java completely and then reinstalling Java 7u13, but Firefox never recognizes it. It does NOT appear in the plugins. In the Java settings through the Java Control Panel, I've noticed that the "Mozilla Family" is unchecked. Even after checking the box, it gets unchecked when I go back and look at it.

Is there a known compatibility issue with Java 7u13 and and FF 18? Is there a way to *force* FF to recognize Java in the plugsin selection? Is FF blocking Java from getting installed? Is there a way to prevent FF from blocking any addons?

Chosen solution

I think I found the problem. I had a Borland Java plugin also installed. Once I removed it, and then re-installed Java 7u13, FF detected it. However, now FF crashes with when I try to load Java. =|

EDIT: Fixed the crash. During all my troubleshooting, I had set dom.ipc.plugins.java.enabled = true. Once i returned this to false, it worked. I'm good now.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Citrix Online App Detector Plugin
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • VMware Remote Console Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.10411.0
  • Version 2.7.5.6365
  • Google Talk Plugin Video Accelerator version:0.1.44.15
  • VMware Remote Console and Client Integration Plug-in
  • ActiveTouch General Plugin Container Version 105
  • AmazonMP3DownloaderPlugin 1.0.15
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6642 answers

Do you have JavaFX installed in the windows control panel? try to remove it

Question owner

I do not have JavaFX installed.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello, in some instances firefox may not be able to detect that the java plugin is installed, because oracle made an error in registering the java plugin for mozilla-based browsers... this will apparently just be fixed with its next release.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8005410

for different workarounds & troubleshooting steps in the meantime see http://kb.mozillazine.org/Java#Windows_installation_issues

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Make sure that you have the 32 bit Java version for 32 bit Firefox installed.

You can find the latest Java version on the Oracle website.

See Java Platform > Java SE 7U13 (Download JRE)

Chosen Solution

I think I found the problem. I had a Borland Java plugin also installed. Once I removed it, and then re-installed Java 7u13, FF detected it. However, now FF crashes with when I try to load Java. =|

EDIT: Fixed the crash. During all my troubleshooting, I had set dom.ipc.plugins.java.enabled = true. Once i returned this to false, it worked. I'm good now.

Modified by jerle78

Question owner

Fixed the crash. During all my troubleshooting, I had set dom.ipc.plugins.java.enabled = true. Once i returned this to false, it worked. I'm good now.

Axis 2 solutions 46 answers

I have found that the easiest way to update the never-ending Java saga is to (on Windows) go into the control panel, click the Java Icon and Update from there.

Hope this helps!

Regards, Axis