X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can caret browsing be fixed so it works properly?

Posted

Windows XP


I'm visually impaired. In the past, I've been using the Windows magnifier while working in Firefox with caret browsing turned on. This made it possible for me to type, and see what I'm typing, because the magnifier would track where the cursor was. If I can't see what I'm typing, and my hand slips and I think maybe I hit a wrong key, I can't see what happened... and I end up with many typos.

I kept the magnifier docked at the bottom of the screen with just enough room so I could see ONE line of text. If I make the magnifier window bigger, more than one line of text confuses my eyes and I can't continue working. Now, with the latest version of Firefox, caret browsing seems to be activated... and it's "trying" to track but things are not working properly.

In the Windows magnifier dialogue box, I check: FOLLOW MOUSE CURSOR, FOLLOW KEYBOARD FOCUS, FOLLOW TEXT EDITING, and these things DO happen in applications I use, and in Firefox version 3.6.28 but not in the latest version of Firefox.

Tracking appears to be happening but the focus point, with the cursor, can't be seen in the magnifier window. Instead, all I see is a different line, one that I'm not working on.

So I uninstalled the latest Firefox and installed version 3.6.28. But it's running very slowly, and I don't know how long I'll be able to use it.

Without the functionality of proper focus on the cursor in firefox with the magnifier, writing email becomes a chore. I have to type in WordPad. I don't have a word processor that works with the magnifier so I check spelling online. I can't do that with the latest Firefox. I can't find the cursor unless the computer finds it for me.

Is there any way all this can be corrected?

Thanx in advance for any help.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96743 answers

Try to disable hardware acceleration in Firefox.


You can use an extension to set a default font size and page zoom on web pages.

Use this extension to adjust the font size for the user interface: