X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Pictures in htm file fail to display.

Posted

As part of a website, I have created an htm file using the Word save-as function to convert a docx file containing both text and imbedded jpg pictures. Firefox displays the text but not the pictures in the htm file. Internet Explorer displays both. I am stumped because I have several other htm files that do display as desired using Firefox.

I am using Windows 7, Word 2010, and Firefox 18.0.1. As far as I know, all are up to date.

Chosen solution

Thanks, but I solved the problem and obviously before you accessed the problem web page. My solution was to save=as using the "filtered" option. I do not know why this worked since I did not use this approach on several other doc to htm conversions.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • npsitesafety
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • HP Product Detection Plugin
  • HP Active Check Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • HP Pit Plugin
  • VLC media player Web Plugin 2.0.2
  • Google Update
  • npFFApi
  • 5.1.10411.0
  • GEPlugin
  • NPWLPG
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24393 answers

Did you upload the pictures too?

If so, do you have the correct path to those images on the server.
If not, that webpage may be looking for those images where they were located when you created that page - on your hard drive.

IE may be pulling those images from Temp files, if you viewed that page while it was still on your hard drive as you were developing that page.

Or, as I recall, IE will display images which are still on your PC. One reason IE isn't as secure as Firefox.

Modified by the-edmeister

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Make sure that you have disabled MS Office VML code when saving the file in Word, otherwise the images may have been saved in a way that only work in IE and that is not compatible with Firefox.

Question owner

Thanks for your response. The problem also occurs when Firefox opens the htm file on my hard drive. When a Word file is saved as a htm, a folder is also created containing all of the images in the docx file. Both the folder and the htm file must be uploaded for the retrieval to work. In this case, it does not.

Question owner

Thanks for your response. The problem also occurs when Firefox opens the htm file on my hard drive. When a Word file is saved as a htm, a folder is also created containing all of the images in the docx file. Both the folder and the htm file must be uploaded for the retrieval to work. In this case, it does not. I have created several htm files using this approach without difficulty. However, I am willing to give your suggestion a try. Can you provide direction to allow me to turn off the VML code?

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Do you have a link to a web page where the images aren't working?

You can also check the images in the Tools > Page Info > Media page to see the actual path and check if the file is on the server.

Also make sure that the image path has forward slashes and not backslashes that Firefox shows escaped as %5C.

Note that you can only load images via a relative path if they are stored in a sub directory of the main html file when opened locally.

Question owner

The website link is http://hrhfh.org/index.html. Near the bottom of this page is a word: Stories. Clicking on this word executes a link (http://hrhfh.org/Stories.htm) that is the problem page. If you explore other tabs on the website, they all utilize the htm approach and work as expected.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24393 answers

http://hrhfh.org/Stories.htm

I am having no problem seeing the 5 images on that page.

Please reload the webpage while bypassing the cache using one of the following steps:

  • Hold down the Shift key and click the Reload button with the left mouse key.

OR

  • Press Ctrl + F5 or Ctrl + Shift + R (Windows and Linux)
  • Press Command + Shift + R (Mac)

See if this helps solve the issues you had and please report back to us!

Chosen Solution

Thanks, but I solved the problem and obviously before you accessed the problem web page. My solution was to save=as using the "filtered" option. I do not know why this worked since I did not use this approach on several other doc to htm conversions.