X
Tap here to go to the mobile version of the site.

Support Forum

firefox is 'rewriting' my homepage

Posted

Windows 7 Professional 64-bit FF 18.0.1

My home page is set to www.yahoo.com When I click on the home icon (or type the same address in the Address bar), the address bar changes to http://www.yahoo.akadns.net/ and the server not found ff built in error page displays I have the live http headers add-on, and there is no actual http request sent.

FF simply will not let me reach www.yahoo.com by typing in the address bar, it always 'rewrites' the address as http://www.yahoo.akadns.net/

I can reach www.yahoo.com in other browsers, via dns (nslookup), and other yahoo addresses (e.g. my.yahoo.com). This sure sounds like malware and is a bit frightening

Windows 7 Professional 64-bit FF 18.0.1 My home page is set to www.yahoo.com When I click on the home icon (or type the same address in the Address bar), the address bar changes to http://www.yahoo.akadns.net/ and the server not found ff built in error page displays I have the live http headers add-on, and there is no actual http request sent. FF simply will not let me reach www.yahoo.com by typing in the address bar, it always 'rewrites' the address as http://www.yahoo.akadns.net/ I can reach www.yahoo.com in other browsers, via dns (nslookup), and other yahoo addresses (e.g. my.yahoo.com). This sure sounds like malware and is a bit frightening

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • Motive Plugin for Mozilla Browsers
  • Octoshape embedded video plugin
  • 5.1.10411.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1 nomagic bot

More Information

philipp
  • Top 10 Contributor
  • Moderator
3013 solutions 13972 answers

hello, try to run a scan for malware with the free version of malwarebytes and adwcleaner & reset firefox afterwards.

hello, try to run a scan for malware with the [http://www.malwarebytes.org/products/malwarebytes_free free version of malwarebytes] and [http://www.bleepingcomputer.com/download/adwcleaner/ adwcleaner] & [[Reset Firefox – easily fix most problems|reset firefox]] afterwards.
Gingerbread Man 403 solutions 1537 answers

It's not malware. It's load balancing. AkaDNS.net belongs to Akamai Technologies, one of the world's largest content delivery networks.

However, you should be seeing www.yahoo.com in the address bar, and the site should of course actually load. See the following article:

It's not malware. It's load balancing. AkaDNS.net belongs to Akamai Technologies, one of the world's largest content delivery networks. * http://answers.yahoo.com/question/index?qid=20060806160840AAykHcT * http://en.wikipedia.org/wiki/Akamai_Technologies * http://en.wikipedia.org/wiki/Load_balancing_%28computing%29 However, you should be seeing '''www.yahoo.com''' in the address bar, and the site should of course actually load. See the following article: * [[Server Not Found - Troubleshoot connection problems]]
philipp
  • Top 10 Contributor
  • Moderator
3013 solutions 13972 answers

however the user agent seems of the question's owner seems to be corrupted (not sure if this might be related to some sort of malicious software)...

however the user agent seems of the question's owner seems to be corrupted (not sure if this might be related to some sort of malicious software)...
heelarious 0 solutions 5 answers

First of all, "akadns.net" is not malware-related but a domain from Akamai. It is/was used for load balancing services. Read more here: http://answers.yahoo.com/question/index?qid=20060806160840AAykHcT and here: http://forums.techguy.org/1325618-post3.html

The weird thing is that you only experience this issue in Firefox and not in other browsers installed on the same machine. I would suggest you to reset Firefox to make sure that no add-on or config is the culprit: http://mzl.la/MnSTZB

Btw: "yahoo.akadns.net" doesn't load for me too.

First of all, "akadns.net" is not malware-related but a domain from Akamai. It is/was used for load balancing services. Read more here: http://answers.yahoo.com/question/index?qid=20060806160840AAykHcT and here: http://forums.techguy.org/1325618-post3.html The weird thing is that you only experience this issue in Firefox and not in other browsers installed on the same machine. I would suggest you to reset Firefox to make sure that no add-on or config is the culprit: http://mzl.la/MnSTZB Btw: "yahoo.akadns.net" doesn't load for me too.

Modified by heelarious

Question owner

But for the Akimai address, it would seem to me that this would require a redirect, i.e. an actual http request being sent?

anyways, very strange that it would just 'rewrite' an address that I manually type in the address bar; perhaps FF 'caches' the redirect? so that it doesn't actually send out an http request? I suppose that's possible

But for the Akimai address, it would seem to me that this would require a redirect, i.e. an actual http request being sent? anyways, very strange that it would just 'rewrite' an address that I manually type in the address bar; perhaps FF 'caches' the redirect? so that it doesn't actually send out an http request? I suppose that's possible
heelarious 0 solutions 5 answers
You could turn off DNS Prefetching and try again: https://support.mozilla.org/en-US/kb/server-not-found-connection-problem#w_dns-prefetching

Question owner

Well, the problem has gone away. Still would like to understand what FF was doing.

The only thing that seems to make sense is that FF cached www.yahoo.com => http://www.yahoo.akadns.net/

and http://www.yahoo.akadns.net/ is no longer a valid domain. but you would think that ff would detect that and invalidate its cache

ps: btw, i did startup ff in safe mode, so it wasn't any add-ons

Well, the problem has gone away. Still would like to understand what FF was doing. The only thing that seems to make sense is that FF cached www.yahoo.com => http://www.yahoo.akadns.net/ and http://www.yahoo.akadns.net/ is no longer a valid domain. but you would think that ff would detect that and invalidate its cache ps: btw, i did startup ff in safe mode, so it wasn't any add-ons
heelarious 0 solutions 5 answers

Well, "madperson" is right, your user agent is weird. In fact it's quite uniqe with that "nomagic bot" included (at least Google says so).

Afaik the default one for you should be: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

So better search for malware I would say...

Well, "madperson" is right, your user agent is weird. In fact it's quite uniqe with that "nomagic bot" included (at least Google says so). Afaik the default one for you should be: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0 So better search for malware I would say...

Question owner

Nah, that's a custom user-agent string I defined for my own purposes.

BTW, how/where did you see that user-agent string? not sure where google fits in (perhaps it was automatically added to the initial support request, but don't see it on this page)

Nah, that's a custom user-agent string I defined for my own purposes. BTW, how/where did you see that user-agent string? not sure where google fits in (perhaps it was automatically added to the initial support request, but don't see it on this page)
philipp
  • Top 10 Contributor
  • Moderator
3013 solutions 13972 answers

your user agent is shown under more system details on the top right section of the page next to your original question - it just looked unusual to me and therefore i've thought it might have something to do with the issue since some toolbars etc. also modify the ua-string...

your user agent is shown under ''more system details'' on the top right section of the page next to your original question - it just looked unusual to me and therefore i've thought it might have something to do with the issue since some toolbars etc. also modify the ua-string...