X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

On version 19 which just downloaded why doesn't the primary search box doesn't work when all other search functions (address box and upper search box) do?

Posted

The primary search box in the center screen does not respond to any search input.

In contrast: (1) the https:// address box responds immediately and normally when input is provided and the curved arrow tapped, (2) the upper search box in line with the address line works normally also when a search inquiry is provided and the magnifying glass tapped, and (3) all bookmarks work normally as they had previously prior to Firefox upgrading to 19.

Everything seems normal with the exception of the center search box and the search command.

Chosen solution

Preciso que traduza a solução: Chosen Solution

hello, first please see if installing the search reset addon can resolve the issue: https://addons.mozilla.org/firefox/addon/searchreset/ (a restart of the browser is necessary afterwards).

otherwise try the following steps in order to manually restore the search function on the default homepage:

   go to firefox > help > troubleshooting information and click on profile folder/show folder. a windows explorer window should open up - in there delete the file named chromeappsstore.sqlite.
   then enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.startup.homepage_override.mstone - right-click and reset that entry to the default value.
   restart firefox
Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello, first please see if installing the search reset addon can resolve the issue: https://addons.mozilla.org/firefox/addon/searchreset/ (a restart of the browser is necessary afterwards).

otherwise try the following steps in order to manually restore the search function on the default homepage:

  1. go to firefox > help > troubleshooting information and click on profile folder/show folder. a windows explorer window should open up - in there delete the file named chromeappsstore.sqlite.
  2. then enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.startup.homepage_override.mstone - right-click and reset that entry to the default value.
  3. restart firefox
cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.


Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Check the browser.search.defaultenginename pref on the about:config page and make sure that it is set to the default value Google.

If you do not keep changes after a restart then see:

Question owner

Thanks! Installing the search reset addon worked like a charm. I didn't need to go any further.

Gemini_57 0 solutions 1 answers

Helpful Reply

I have tried all the so-called fixes listed here, but since downloading version 19, I can't get the search box to work. If I go through and try the fixes here, it works until I shut it down, and then I have to go through all these steps again. Trying to get someone to help is virtually impossible, and I am getting to the point where I will uninstall Firefox and use IE, as I have no other choice!

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Which search box do you mean?

  • searching via the location bar (pref: keyword.URL)
  • search bar on the Navigation Toolbar
  • search bar on the about:home page (pref: browser.search.defaultenginename)
  • other search bar (e.g. added by extension)

If you do not keep changes after a restart then see:

marciovallim 1 solutions 2 answers

Chosen Solution

Preciso que traduza a solução: Chosen Solution

hello, first please see if installing the search reset addon can resolve the issue: https://addons.mozilla.org/firefox/addon/searchreset/ (a restart of the browser is necessary afterwards).

otherwise try the following steps in order to manually restore the search function on the default homepage:

   go to firefox > help > troubleshooting information and click on profile folder/show folder. a windows explorer window should open up - in there delete the file named chromeappsstore.sqlite.
   then enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.startup.homepage_override.mstone - right-click and reset that entry to the default value.
   restart firefox