X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

this connection is untrusted appears in youtube

Posted

this connection is untrusted keep appears in youtube ,when i open youtube the advertisement become this error msg ,and cannot click ,no option. when i start firefox, keep pop up checking your add-ons msg ,i don't know how to disable it , it annoying.i don't know it have a connection or not,but all the problem appears after i install avast free antivirus,i use firefox 18.0.1.

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.0 d1
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96741 answers

Does it work if you use a normal http link?

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

thank first.the youtube problem is solve,but the checking your add-ons still pop up whenever i start firefox.i already clear the cache and cookies,try to start firefox in safe mode and check the default theme, but all these don't seem to solve my problems.and firefox always open up with two tabs along with 'welcome to firefox' ,how to disable it?

Gimikus 0 solutions 2 answers

I also have same problem.

I tried to clear everything as cor-el wrote, but I still have this problem.

http://www.youtube.com- works fine https://www.youtube.com - shows what connection in Untrusted

Do you have any ideas what it could be?

Thanks a lot Jevgenij L.

Modified by Gimikus

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96741 answers

Note that https://www.youtube.com/ has mixed content (i.e. some content comes via an unencrypted http connection).

You can see this in the "Web Developer > Web Console" (Ctrl+Shift+K) as lines marked in red text with [Mixed Content] added.

Gimikus 0 solutions 2 answers

Actually I can’t open any page what could be accessed thought HTTPS. I have attached warning message.

I tried to reinstall Browser.
cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96741 answers

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.