X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Paragraph spacing is lost when copy and pasting from a Word Document

Posted

Feburary3, 2013

For the past few weeks I have had this problem. I know that it is a Firefox issue, as it does not happen with Internet Explorer. I have reset Firefox to Default, but the problem remains.

Problem: After creating a document in Mircrosoft Word, I copy the document and then paste it within and e-mail message. Within the e-mail, all paragraph spacing is erased.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • Shockwave Flash 11.5 r502
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • NPWLPG
  • 5.1.10516.0
  • DeLorme Send To GPS
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Package Installer & Install Conduit

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

It may be happen because of text Zoom or Change of font

Question owner

I liked the No Squint extension . Thanks. However, it did not make any difference in the problem I am having with using Firefox as a browser, when I want to copy and paste a Word Document into an e-mail message.

I tried and still have the lines erased between paragraphs.

I tried copying the Word Document before opening Firefox, but that made no difference.

Can you recommend an extension or add-on that can be used for copying and pasting Microsoft Word Documents into a e-mail message using Firefox as the browser?

I do appreciate any help, as I like Firefox and want to keep it as my default browser.

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Please create a screenshot of the problem you're seeing by following the guide mentioned at How do I create a screenshot of my problem?.

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Question owner

I have uploaded a screenshot of the way a Copy and Paste Word Document is distorted when embedded in an e-mail message. Note that the line spacing between paragraphs are missing from the body of the text.

I have also uploaded a screenshot of the Word Document that I Copy and Pasted into the e-mail message so you can see where the paragraph spacing should be.

Again, this appears only when Firefox is the browser.

Hope you can help. I like Firefox and want to use it at all times, rather than going to Internet Explorer for some things like Copy and Pasting.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8020 answers

Hi Birder,

You may easily add additional blank lines on the email.

It is probably not to be expected that an emailer and Word would have the same formatting and in any event you will be effectivly pasting it in as a.txt document, so look at what the document is like saved as .txt.

Also remember the email will look different depending on for instance the screen size, just try changing your window size to 1/2 size and watch what happens, to the email.

Does your email allow attachments, almost all do, if so send the document as an attachment.

Helpful Reply

John, your advice was of no avail in resolving the problem.

First, there are many extra lines to add. There is a line after each species, etc. Why would I want to take those extra steps?

Second, I received a copy back from a receiver. When I did add the spacing lines in a message, his e-mail showed two spaces between where I had added only one.

Sizing of the document, does not make any difference whatsoever. I tried that.

As a backup to all, I do add a PDF document as an attachment. But I want to embed the document directly into an e-mail message too. Those receiving the reports have asked for it. They can read the first few lines and decide to continue or not.

I save the document as a Word.doc.

Why would the paragraph spacing be erased between a Copy command of a Word Document, and a Paste Command using Firefox as a browser?

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8020 answers

Hi Birder,
Sorry my last answer was of no help, I will try again with a longer answer.

First of all I must explain this is NOT a Firefox problem is down to incompatibilities between a Word formatted document and what your email system may handle.

On your Word menu/ribbon you have an icon ¶
Click that icon whilst your problem word document is open.
Similar symbols will appear in your document, mostly at the ends of paragraphs.

Most of the other line endings in your document are probably because of your margin settings. Emails do not understand margin settings. Emails also do not understand spacings between paragraphs, but they will either start a new line, or perhaps start a new line and add a blank line.

Try typing into this forums reply box you will see something similar happen. Try to copy the following italic text.

a short line then I hit the return key
another short & return
and again

You will see that as you type, now hit the preview and it will change to
a short line then I hit the return key another short & return and again!

Your email system is doing something similar.

Your Word letter is line wrapping at something like 80 characters.your email is line wrapping at something like 140 chars. What does this forum use about 70 chars?

As for the window width I was trying to point out you have no control over the width the person receiving it is using. It may be a feature phone with only a few words per line, it may be a smartphone with a screen that may be used landscape or portrait, or it may be a widescreen desktop.

Consider previewing your information in plain text in notepad to see what it looks like at different window widths. Send the formatted document as an attachment maybe Word & or pdf, but you have to put up with the limitations of the email itself. If you do not want to add manual line breaks maybe consider some macro for doing that.

 Why would the paragraph spacing be erased between a Copy command of a Word Document, and a Paste Command using Firefox as a browser?  

I doubt it is erasing the paragraph ends look for the ¶. But as I said it will not be able insert say a 1/2 inch (1cm) spacing.
Try using IE you will get a similar result, it is not the fault of the browser. (Unless both the browser and the email system understand and support Word's formatting )

I hope that makes things a little clearer, although obviously it is not a magic cure for your problem.

Question owner

I have tried to follow the instructions given, but I still have the same problem, when copying a Word Document, and then pasting directly into an e-mail message. The paragraph spacing disappears, and only single spacing remains.

I see the paragraph signs in the Word Document, at the end of each line that I space as for a paragraph. The spacing between paragraphs is just not carried over in the Copy and Paste actions in a Comcast e-mail with Firefox as the browser.

I have tried to change paragraph spacing in MS Word document from Auto, to 6 pt, 12 pt. Before and After Paragraphs but to no avail.

I even had a computer specialist work on the problem. The only "work around" was to use a special paste option and send the e-mail through Outlook. He could not fix the actual problem, with Microsoft Word, Comcast, and Firefox and restore what I was able to do without problem in the past with these three systems.

It is likely some simple setting that I just don't understand or cannot identify that would correct the problem. I was able to use Copy and Paste before directly into a Comcast e-mail and Firefox browser. I can still do so with Internet Explorer as a browser, using Comcast e-mail and it works fine.

But I would really like to be able to have the Copy and Paste work as it did before. I just don't know how to fix this problem, or where to go for help, other than here.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8020 answers

I am not currently a Word user unfortunately. I do not know what plugins or cross functionality Word may have. I may for example expect it to have the ability to let a downloaded Word document be loaded into either a Firefox Tab customised for Word or be cached and opened directly into a Word document.

Something similar to what may happen with pdf files, using either the Firefox pdf viewer, or after installing a standalone product for reading pdf files.

Possibly MS forums would have some further information. I did find this which may be worth reading

Unless you are able to change the line spacing directly in the email,it is probably better to put in a double blank line as a separator. If the email does not allow such repeats then use a blank line a dash and a second blank line.

Sorry I have not really got any more ideas.

Modified by John99