X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox can't load xpcom how do a novice fix it ?I did a firefox uninstall and reinstalled and it still doesn't work

Posted

xpcom won't load after a new install of firefox. i did virus scans and the whole nine yards and i still get the error message. My system is xp sp3. Firefox will not start

Chosen solution

Could you please provide a screenshot as well as steps as to how you got that error message?

Read this answer in context 4

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17

More Information

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3016 answers

Chosen Solution

Could you please provide a screenshot as well as steps as to how you got that error message?

Question owner

I fixed it i got a copy of msdmo.dll from my backup hard drive,deleted the one on C: drive and pasted the one from my backup to C: and its working now. thanks everybody  :-)

Question owner

Also no more xpcom will not load

Question owner

I didn't do anything Firefox updated and then i got the error