X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

my ? was why do I keep getting a notice to update after I've updated and saved, how many times do i have to save the damn thing before it takes?

Posted

I am on windows. Every time I try to go on line a prompt tells me I'm not on the latest version of fire fox. I then download and save, but afterward when i try to go on line i keep getting the very same prompt telling me i'm still on the latest version of fire fox. The version downloaded successfully several times now. For the life of me I don't understand this, how many times do i have to download and save before it takes. I to the point that i tempted to use another browser. What in the world could be causing this because since i've done this my computer is as slow as molasses?

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape
  • Default Plug-in
  • 15.0.1.13
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Shockwave Flash 11.5 r502
  • Picasa plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_38 for Mozilla browsers
  • 5.1.10411.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • My Web Search Plugin Stub for 32-bit Windows
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • Google Update
  • Yahoo! activeX Plug-in Bridge
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6638 answers

Helpful Reply

Try following the steps found at Websites say that Firefox is outdated or incompatible even though it's the latest version

After doing that use Update Firefox to the latest version to ensure you are running Firefox 18.0.1