X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I only see the Java Deployment Toolkit plugin listed in the Add-ons

Posted

Hello everyone,

I only have Java Deployment Toolkit plugin 7.0.110.21 listed and enabled, and not Java Platform SE.

I tried the steps under: http://kb.mozillazine.org/Java#Enabling_Java, but nothing works.

Help! :-)

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.5 r502
  • Nokia Suite Enabler Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • VLC media player Web Plugin 2.0.2
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Autofill Engine for Gecko and Webkit-based web browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.10411.0
  • Garmin Communicator Plug-In 4.0.1.0
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • 1,1,1850,0
  • Downloader Detector
  • 1.9.0009.1
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • WindizUpdate for Firefox, Mozilla, Opera and Netscape; version 2.0.2007.0309. For details, visit windizupdate.com
  • Office Plugin for Netscape Navigator
  • PDF-XChange Viewer Netscape Gecko Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello, in some instances firefox may not be able to detect that the java plugin is installed, because oracle made an error in registering the java plugin for mozilla-based browsers in version 7u10 & 7u11... this will apparently just be fixed with its 7u13 release.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8005410

for different workarounds & troubleshooting steps in the meantime see http://kb.mozillazine.org/Java#Windows_installation_issues

Question owner

I tried everything on the link you provided, but I could not get any version 7 plugin to work. I am now back on the latest Java SE 6, which is working fine