X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

opens with tabs from previous session

Posted

After automatically updating to v18.0.1 a new session of FF now opens with all of the tabs that were open when I closed the previous session. How can I get it back to where a new session opens only with my home page?

Chosen solution

Ah Hah! That worked, so it appears that it's an Tab Mix Plus issue.

Thanks

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Amazon MP3 Downloader Plugin 1.0.17
  • VLC media player Web Plugin 2.0.2
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Google Update
  • GEPlugin
  • 5.1.10411.0
  • Logitech Device Detection
  • NPWLPG
  • np-mswmp
  • Yahoo! activeX Plug-in Bridge

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Change your Home Page Setting

Tools > Options > General > StartUp

When Firefox Starts > Choose the Show my Home Page

Question owner

That's how I've always had FF set. Here's the settings for FF and Tab Mix Plus. This issue just started with the update to v18.

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Disable you "Tab Mix Plus" extension and try it

Chosen Solution

Ah Hah! That worked, so it appears that it's an Tab Mix Plus issue.

Thanks

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Check whether your addons are updated or not...

Question owner

They are all up to date.

I've marked the problem as solved.

Thanks again for the suggestion

TheOldFox 110 solutions 619 answers

Helpful Reply

The TabMix Plus setting pictured above shows you have selected "Startup Session: Last Session". Change that option. You will need to adjust the settings on the "Session" tabs in TMP; I do not use the TMP Session manager (I use the Session Manager extension instead), you can not use both SM and TMP Seesions, so I can not advise you of the settings. Following is the TMP Manual (there are 3 sections for the Session tab.

You can also register and inquire at the TMP forum - http://tmp.garyr.net/forum/index.php

Question owner

OldFox - I've installed the Session Manager and set it to open with my home page. Works so far, so hopefully all is solved.

Thanks to both of you.