X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does Firefox take me to a page that says, "Oops Page cannot be found" when I click on a link in a secure site. Not with IE: only Firefox.

Ed
Posted

If I go to a secure site and click on a link, it take me to "Oops Page cannot be found". I have reset Firefox, uninstalled it and re installed it, disabled my Add Ons, and every other suggestion from the forum. Nothing works and this does not happen with IE. Is the bottom line that I must use IE for these sites? I would prefer Firefox but cannot solve this problem.

Chosen solution

You found it, Buddy. It was my AVG Security Toolbar. Will my computer be vulnerable to viruses if this is disabled?

Again, thanks so much for your time.

KUDOS TO MODERATOR who solved the problem.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • npsitesafety
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • 5.1.10411.0
  • wpidetector
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Question owner

I forgot to mention that the page I click on briefly appears and, within a second, jumps to that page "Ooops. Page not found". I don't understand because it was there for a second, I could see everything on the secure site, but it disappears.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Helpful Reply

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

It worked in safe mode after doing what you said and disabling Add Ons. When I restarted it, it did the same thing. How do I know which Add On is causing this?'

Thank you for your time.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Helpful Reply

Did you disable all the extensions before restarting?

If it works in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used (localstore-safe.rdf)
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected

Modified by cor-el

Chosen Solution

You found it, Buddy. It was my AVG Security Toolbar. Will my computer be vulnerable to viruses if this is disabled?

Again, thanks so much for your time.

KUDOS TO MODERATOR who solved the problem.

Modified by Ed