X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot make download window clear automatically

Posted

Using WIndows 7 Ulitmate and Firefox 17-18 on desktop and laptop, both set up same way. On laptop, cannot make download window stop saving download history; has to be manually cleared. This began at least with v17 or before, and upgrading to v18 didn't change it. Have dechecked "remember browsing & download history" and even that doesn't work. A related issue is that what I really want, which is apparently no longer available in newer versions of Firefox, is to have custom history setting which saves search & form history (until manually cleared), saves browsing history for (xx) days, but does NOT save any download history, particularly in the downloads window. This used to be possible and work fine in previous versions. Now it appears one cannot set the time to save browsing history (either yes or no), and cannot separate browsing history from download history. Seems like the 'upgrades' have actually reduced the options available (Oh, how I miss FF 5-6!)

Chosen solution

Did you look at these prefs?

  • browser.download.panel.removeFinishedDownloads = true
  • browser.download.manager.retention = 0
Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • Google Update
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version 3.10.2.10212
  • LightshotPlugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

{
"application": {
"name": "Firefox",
"version": "18.0.1",
"userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0",
"supportURL": "http://support.mozilla.org/1/firefox/18.0.1/WINNT/en-US/"
},
"modifiedPreferences": {
"accessibility.typeaheadfind.flashBar": 0,
"browser.cache.disk.capacity": 358400,
"browser.cache.disk.smart_size.first_run": false,
"browser.cache.disk.smart_size.use_old_max": false,
"browser.cache.disk.smart_size_cached_value": 358400,
"browser.places.smartBookmarksVersion": 4,
"browser.startup.homepage": "http://www.google.com/",
"browser.startup.homepage_override.buildID": "20130116073211",
"browser.startup.homepage_override.mstone": "18.0.1",
"browser.tabs.onTop": false,
"browser.tabs.loadInBackground": false,
"dom.ipc.plugins.enabled.npietab2.dll": true,
"extensions.lastAppVersion": "18.0.1",
"network.cookie.prefsMigrated": true,
"places.history.enabled": false,
"places.history.expiration.transient_current_max_pages": 100623,
"places.database.lastMaintenance": 1358929677,
"privacy.donottrackheader.enabled": true,
"privacy.sanitize.migrateFx3Prefs": true,
"security.warn_viewing_mixed": false
},
"graphics": {
"numTotalWindows": 1,
"numAcceleratedWindows": 1,
"windowLayerManagerType": "Direct3D 10",
"adapterDescription": "NVIDIA GeForce 9100M G",
"adapterVendorID": "0x10de",
"adapterDeviceID": "0x0844",
"adapterRAM": "256",
"adapterDrivers": "nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um",
"driverVersion": "8.17.12.9610",
"driverDate": "2-29-2012",
"adapterDescription2": "",
"adapterVendorID2": "",
"adapterDeviceID2": "",
"adapterRAM2": "",
"adapterDrivers2": "",
"driverVersion2": "",
"driverDate2": "",
"isGPU2Active": false,
"direct2DEnabled": true,
"directWriteEnabled": true,
"directWriteVersion": "6.1.7601.17789",
"webglRenderer": "Google Inc. -- ANGLE (NVIDIA GeForce 9100M G)",
"info": {
"AzureCanvasBackend": "direct2d",
"AzureFallbackCanvasBackend": "cairo",
"AzureContentBackend": "direct2d"
}
},
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false,
"forceDisabled": 0
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.9.4",
"version": "4.9.4"
},
"NSS": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
},
"NSSUTIL": {
"minVersion": "3.14.1.0",
"version": "3.14.1.0"
},
"NSSSSL": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
},
"NSSSMIME": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
}
},
"extensions": [
{
"name": "Adblock Plus",
"version": "2.2.1",
"isActive": true,
"id": "{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}"
},
{
"name": "Adblock Plus Pop-up Addon",
"version": "0.5",
"isActive": true,
"id": "adblockpopups@jessehakanen.net"
},
{
"name": "BetterPrivacy",
"version": "1.68",
"isActive": true,
"id": "{d40f5e7b-d2cf-4856-b441-cc613eeffbe3}"
},
{
"name": "BrowserProtect",
"version": "1.1.3",
"isActive": true,
"id": "browserprotect@browserprotect.com"
},
{
"name": "ColorfulTabs",
"version": "17.6",
"isActive": true,
"id": "{0545b830-f0aa-4d7e-8820-50a4629a56fe}"
},
{
"name": "Copy Urls Expert",
"version": "2.1.0",
"isActive": true,
"id": "copy-urls-expert@kashiif-gmail.com"
},
{
"name": "DownloadHelper",
"version": "4.9.13",
"isActive": true,
"id": "{b9db16a4-6edc-47ec-a1f4-b86292ed211d}"
},
{
"name": "Ghostery",
"version": "2.8.4",
"isActive": true,
"id": "firefox@ghostery.com"
},
{
"name": "Google Image Help",
"version": "3.1",
"isActive": true,
"id": "googleimagehelp@shivam.org"
},
{
"name": "IE Tab 2 (FF 3.6+)",
"version": "4.12.22.2",
"isActive": true,
"id": "{1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}"
},
{
"name": "Java Console",
"version": "6.0.37",
"isActive": true,
"id": "{CAFEEFAC-0016-0000-0037-ABCDEFFEDCBA}"
},
{
"name": "Lazarus: Form Recovery",
"version": "2.3",
"isActive": true,
"id": "lazarus@interclue.com"
},
{
"name": "Lightshot (screenshot tool)",
"version": "3.0.0",
"isActive": true,
"id": "{394DCBA4-1F92-4f8e-8EC9-8D2CB90CB69B}"
},
{
"name": "My Homepage",
"version": "1.2",
"isActive": true,
"id": "myhomepage_manishjain9@gmail.com"
},
{
"name": "ProxTube - Unblock YouTube",
"version": "1.4.3",
"isActive": true,
"id": "ich@maltegoetz.de"
},
{
"name": "Redirect Remover",
"version": "2.6.4",
"isActive": true,
"id": "{fe0258ab-4f74-43a1-8781-bcdf340f9ee9}"
},
{
"name": "Resurrect Pages",
"version": "2.0.7",
"isActive": true,
"id": "{0c8fbd76-bdeb-4c52-9b24-d587ce7b9dc3}"
},
{
"name": "Search by Image for Google",
"version": "1.2.0",
"isActive": true,
"id": "{ab4b5718-3998-4a2c-91ae-18a7c2db513e}"
},
{
"name": "Show my Password",
"version": "2.0",
"isActive": true,
"id": "{cd617372-6743-4ee4-bac4-fbf60f35719e}"
},
{
"name": "StumbleUpon",
"version": "4.16",
"isActive": true,
"id": "{AE93811A-5C9A-4d34-8462-F7B864FC4696}"
},
{
"name": "YouTube to MP3",
"version": "1.2.3",
"isActive": true,
"id": "youtube2mp3@mondayx.de"
},
{
"name": "Logitech Flow Scroll",
"version": "4.00.33",
"isActive": false,
"id": "{5D3F3872-91E9-4d59-AD9F-AA174A3145DD}"
}
]
}

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96644 answers

Current Firefox versions store the downloads in the Downloads folder in the History Manager (Library)

  • History > Show All History

Those are still there even if you delete the entries in the classic download manager window.

Involved prefs:

  • browser.download.panel.removeFinishedDownloads = true
  • browser.download.manager.retention = 0

Note that search & form history automatically expires.
See:

Question owner

OK, so if I understand correctly, it'll go away on its own after 180 days. No good. I want it to clear from the download list (Ctrl + J) automatically the way it used to, without having to push the 'Clear List' button. It does on my desktop, but does not on my laptop. The laptop is currently not saving ANY history in an attempt to make it quit; there are no downloads at all listed in history, but they are all on the download list window. So there is now no way to save browsing history, but NOT save download history? Or my download history was always saved (for my custom setting of xx days) with browsing history and I just didn't know it? I'm more confused than before.

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96644 answers

You can override that with a hidden Integer pref browser.formfill.expire_days (bug 243136) that needs to be created.

// Determine how many days of history we're supposed to keep.
let expireDays = 180;
try {
      expireDays = Services.prefs.getIntPref("browser.formfill.expire_days");
} catch (e) { /* ignore */ }

Question owner

This is an exercise in frustration and futility. I'll just live with it. You're speaking a different language from the ones I know. This looks like Greek (well, Geek). I'm not a programmer, just a simple-minded user. Guess I should just shut up and go back to IE. There are 10 types of people--- those who understand binary and those who don't. Guess I don't.

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96644 answers

Helpful Reply

Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar.

If you see a warning message then you can confirm that you want to access the about:config page.

If you right-click on the about:config page then you see a context menu.
In that context menu select: New > Integer
For the name of the string copy/paste this text: browser.formfill.expire_days
Click OK and enter the preferred number of days as the value (e.g. 365 for one year; don't exaggerate and make it extremely large).

Make sure that the name doesn't have leading or trailing spaces.

See also:

Question owner

Thanks! That fixed the Browsing History to delete after 30 days. But to the original issues which prompted this post, is there a similar entry (or some other way) to make the Classic Download window (Ctrl + J) clear my list after downloading, as it used to do? As I mentioned, it was still doing it even when I had changed settings to save NO history (dechecked "Save Browsing & Download History" in Options)

Modified by Musicalman7

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96644 answers

Chosen Solution

Did you look at these prefs?

  • browser.download.panel.removeFinishedDownloads = true
  • browser.download.manager.retention = 0

Question owner

Well, I looked for them but there were so many choices I didn't look at them; couldn't find the right ones. That fixed it. Thanks SO much! I'll try to remember to check about:config next time I have a problem. Awesome.

Modified by Musicalman7

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96644 answers

You're welcome.

See also: