X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

External links suddenly open in a new window instead of a tab

Posted

I am using Nightly (20.0a1) on WIndows 8, I use the program Teamspeak 3 and it used to be that whenever I clicked on a link it would just open in a new tab in the Nightly window that was open, but now it opens a completely new Nightly window. I have the box ticked in settings, I've gone through all of the about:config things I've seen online and nothing works, I really have no idea what to do. I just did something with envoirenmental variables which didn't help (meant that it opened a whole new instance of Nightly whenever I clicked on an external link) so I deleted the variable. Anyone got any suggestions? If it is relevant, before this problem started I dragged a tab from one window of Nightly to another (think it might've been the cause of this), and yes, I've tried dragging tabs around from window to window to fix this and it didn't work.

Modified by badman454

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.10.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502

Application

  • Firefox 21.0a1
  • User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:21.0) Gecko/20130126 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0a1/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 560
  • adapterDescription2:
  • adapterDeviceID: 0x1201
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 0 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16433
  • driverDate: 12-29-2012
  • driverDate2:
  • driverVersion: 9.18.13.1090
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 )
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow.override.external: 3
  • browser.link.open_newwindow.restriction.override: 2
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.startup.homepage: https://www.google.co.uk/
  • browser.startup.homepage_override.buildID: 20130126030941
  • browser.startup.homepage_override.mstone: 21.0a1
  • browser.tabs.warnOnClose: False
  • browser.tabs.warnOnOpen: False
  • browser.urlbar.default.behavior: 2
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0a1
  • font.name.serif.x-western: Arial
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • network.http.max-connections: 48
  • network.http.max-persistent-connections-per-proxy: 8
  • network.http.max-persistent-connections-per-server: 4
  • network.http.pipelining: True
  • network.http.pipelining.maxrequests: 100
  • network.http.proxy.pipelining: True
  • places.database.lastMaintenance: 1358703982
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.default_personal_cert: Select Automatically
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10744 solutions 96670 answers

Try set the browser.link.open_newwindow.override.external Boolean pref to 3 on the about:config page.

Helpful Reply

Thanks, but I already had it set to that, I've heard of many people with this problem and tried literally all fo the about:config fixes that I could find but none worked, I think it is some sort of assosiation problem with hyperlinked text with windows but I really don't know. Anyone who can help me please do, this is getting annoying. Keep in mind that I have Windows 8 when making suggestions also.