X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox keeps hanging ("not responding") every couple of minutes consistently. Nothing works to stop that

Posted

I've gone through all the suggestions, troubleshooting listed here and nothing has worked in stopping this "hanging" business. It started earlier this week with FF16. So I tried uninstalling, clearing out any traces of it, profiles and all. R-installed with the previous extensions, plugins and scripts. Still did it. So I either disabled or uninstalled said add-ons. Still did it. Upgraded to 17, then 18. Same problem. "Not responding" every couple of minutes for just a few seconds, longer when I switched tabs. I'm a heavy tab user, but given the problem, I've gone down to no more than 3 open at the same time. Still hangs. So I decided to do a complete overhaul. Did a reset. I even thought it was my computer (Vista with SP2) which had been working fine and was slowing down around the same time FF was hanging and being a resource hog.

With FF uninstalled, with the help of Microsoft support, I worked on the laptop. Uninstalled my usual programs, including AV (which had avast). Moved all my files to an external hard drive. In essence leaving my computer with bare bones. Did a defrag and a system restore. I reinstalled av, then ran it. All clear. Ran malwarebytes. All clear. Ran registry clean. All fine. So I reinstalled FF18 and did not use any add-ons. Still hanged. Went up to FF19 beta thinking whatever but there is, would be cured. And it worked fine witn no add-ons. So I started installing my usuals, but leaving only the most important ones, ABP, No Script. Was ok so I added greasemonkey, smartest toolbar, download statusbar and unhide passwors. All which I've used for years with no problems. And FF19 worked fine with no hanging for like a day and a half. Today, (jan 24) not only is it haning and not responding again, but it's doing it more frequently and for longer.

FF never has crashed, it just hangs and freezes. My job is ALL online. I don't like Chrome (not user friendly to me). I'd rather avoid using IE. I'm a user of FF since day one, but this is stressing me out because I cannot do my job properly.

What can I do to make it stop? My only other option is to just forget FF and try and get used to Opera.

Now that I think about it, could this hanging problem be related to the Java issue that has come out publicly recently?

I don't know what else to do. I've tried everything that has been written here. Trust me, I've wasted 2 days on this issue. Time I'll never get back and I could've used to do work.

Thanks

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • Shockwave Flash 11.5 r502
  • NPRuntime Script Plug-in Library for Java(TM) Deploy

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

nginx-hosting.co.uk 0 solutions 2 answers

I have had this same problem for quite a while and it got so annoying that I decided to delve further into the matter.

FF would hang for 1-2 seconds every time I performed an action such as switched tabs / click a hyperlink etc.

I tried all the usual methods, uninstalled extensions, disabled plugins, stopped JS running, cleared cache, history, i even thought it was other programs on my machine causing the problem so closed everything but FF.

Still I had the same issue - that was until I disabled FIREBUG - then the problem went away (im using over 600MB of FF memory right now).. Later I re-enabled firebug and the problem came back

This is definetely a FIREBUG problem.

To resolve, click Tools -> Add Ons -> Extensions and find firebug and click DISABLE.

I've reported the above problem to the plugin developer and will keep you guys posted.

Nan65 0 solutions 2 answers

Well I looked for Firebug under the Extensions and I don't have it listed to disable so not sure that's my problem. I had uninstalled and reinstalled Firefox at some point so maybe that's why it doesn't show up on the extension list?? For now I've given up on Firefox altogether and I'm back to using IE. Never thought I'd do that but no choice at this point. I'll keep checking back for answers though. Thanks.

ljp88 0 solutions 5 answers

Yep, nginx-hosting.co.uk, I experienced the same thing you have.

I disabled Firebug yesterday and it's been nothing but smooth sailing. Except for the fact that I use Firebug constantly.  ;) I've resorted to using the developer tools "inspect element" in Chrome for the moment. Not the same, but a lot less frustrating than trying to work in a browser that keeps hanging.

SevenThunders 0 solutions 3 answers

I've never even used Firebug so that wasn't the issue for me. Interestingly I recently had to reinstall my linux operating system on one of my hard drives, Mint 15 cinnamon was the distro.

It comes with a version of firefox default. Well the darn thing actually works. It's amazing. I haven't had any hangs attributable to Firefox or flash since I've installed it. It's version is Firefox 21 right now.

Of course nothing has changed on my other computers or on windows. I haven't even installed chromium yet. I'm waiting for the first crash before I do that.

nginx-hosting.co.uk 0 solutions 2 answers

ljp88 - I love firebug and use it on a daily basis about 20 times per day lol. I love the inline editing of the styles - saves me so much time. What a great plugin, its such a shame that its causing FF to hang every click.

Nan65 - Sounds like yours is actually a FF issue. If you post a video on youtube or similar so I can see the exact problem I might be able to diagnose for you.

SevenThunders - Reading this, it would be the latest update thats causing the FF slow / hang issue. If it comes back let me know.

ljp88 0 solutions 5 answers

nginx-hosting.co.uk -- yes, I use firebug on a daily basis as well...too many times to count. So many web developers/designers like me don't know how we lived without it.  :) But now, it's just impossible to run with Firefox.

It's been two days since I disabled Firebug and Firefox runs just fine. I've had zero problems.

arvindkumar 0 solutions 1 answers

Hello All, Even I have the same issue. Mine is a Win 7 Home premium - 64 bit - FF v21.0. This is very irritating and I have tried the following solutions:

1. Killing the process in Taskmanager and restarting 2. Powering the system and starting it fresh 3. Uninstalling and reinstalling FF 4. Renaming the FF profile 5. msconfig check in cmd 6. sfc/checknow in cmd to check bad files 7. Registry error checks, Anti-virus deactivate/skype uninstalled 8. Hardware acceleration off 9. Plugins updated/removed 10. Malware/virus/bot checked - all clean

The other issue I have is, if I do a clean install of FF, it does work - period! Once I shut down the system and start it a later time - the problem reoccurs. I do not let the system to hibernate or sleep rather I shut it down completely.

I see that many have tried almost all of the above discussed solutions without any success. I would very thankful if any FF contributor/architect could check it in detail. Chrome/IE works without any glitch but I prefer FF, as every other person here. Any other suggestions welcome.

Thanks in advance.

Modified by arvindkumar

saviour321 0 solutions 1 answers

here the list my crash....please fix it..

d6b20f5a-8e69-49e4-a103-827d443b279d 6/25/2013 5:35 PM

bp-b9ae6069-9dda-4252-8ac8-fbd412130702 7/2/2013 2:14 PM

bp-7903b3e1-3795-401d-848f-f0a022130702 7/2/2013 2:19 PM

jscher2000
  • Top 10 Contributor
2387 solutions 21097 answers

Hi saviour321, I think there are too many unrelated problems in this thread. However, your crashes appear to be related to Flash.

This is some standard guidance that addresses the most common issues. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?


Also, most people who come here with the Default Tab extension prefer to remove it. To rule out potential conflicts, disable ALL nonessential or unrecognized extensions on the following tab. If in doubt, disable:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Most likely you will need to restart Firefox before that takes effect.