X
Tap here to go to the mobile version of the site.

Support Forum

Why doesn't Firefox display all photos posted on Facebook?

Posted

Firefox will display some, but not all, photos posted by my friends on Facebook. IE8 displays them all. Do I need to reconfigure FireFox settings to see all photos posted on Facebook?

Firefox will display some, but not all, photos posted by my friends on Facebook. IE8 displays them all. Do I need to reconfigure FireFox settings to see all photos posted on Facebook?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Google Update
  • IE Tab plugin
  • GEPlugin
  • Google Updater pluginhttp://pack.google.com/
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Provides additional functionality on Facebook. See our web site for details.
  • 1.7.0069.3
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Windows Multimedia Services DRM Store Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1271 solutions 8418 answers
Update to Firefox 18.0.1 [[Update Firefox to the latest version]] Then read [[Websites look wrong or appear differently than they should]]
cor-el
  • Top 10 Contributor
  • Moderator
12922 solutions 118514 answers

Helpful Reply

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.image pref should be 1.

There are also extensions like Adblock Plus (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

If images are missing then check that you aren't blocking images from some domains. *Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions" *Check that images are enabled: Tools > Options > Content: [X] Load images automatically *Check the exceptions in "Tools > Options > Content: Load Images > Exceptions" *Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key). If an image in the list is grayed and there is a check-mark in the box "<i>Block Images from...</i>" then remove that mark to unblock the images from that domain. Make sure that you do not block third-party images, the permissions.default.image pref should be 1. There are also extensions like Adblock Plus (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content. See also: *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *http://kb.mozillazine.org/Images_or_animations_do_not_load

Helpful Reply

Thanks. "*Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key). " fixed the problem.

Thanks. "*Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key). " fixed the problem.