X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

i am using windows 7 a program I am using requires firefox 2.0xx

Posted

Close

Software Check Results


The following are the results from the software check:

   Firefox 10.0.2 - We don't support versions above 2.0.x.x.
    
       Supported browsers:
       Internet Explorer (Supported version is between 6.0 and 7.0.)
       Mozilla Firefox (Supported version is between 2.0 and 2.0.x.x.)
       Safari on Mac (Supported version is between 3.0 and 3.1.)
   Java 1.6.0.37 - You have the correct version installed and enabled.
       Supported version is 1.5 and above.
   Adobe Reader 8.0+ - You have the correct version installed and enabled.
       Supported version is 7.0 and above.

This is the info I need help with thank you

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • My Web Search Plugin Stub for 32-bit Windows
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

James
  • Top 25 Contributor
  • Moderator
437 solutions 3152 answers

Not sure why they refer to 2.0.0.x as 2.0.x.x when all security updates was 2.0.0.x with 2.0.0.20 being last back in December 18, 2008.

You could perhaps use the portable Firefox 2.0.0.20 version either on hard drive in its own folder or on a usb flash drive just for this old program. This will not affect your Firefox install.


Also the Firefox 10.0.2 is old and vulnerable as it was the last 10.0 on the release channel at time and a a ESR channel continued it to 10.0.12esr. However if you really do not want to do major version updates then perhaps use the 17.0.2esr at least as the 10.0.*esr channel support will end when Firefox 19.0 is released.

[fixed links - c]

Modified by cor-el

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96736 answers

Helpful Reply

Are you sure that the software doesn't work with current Firefox versions?

This looks like a really outdated message.


There are other things that need your attention.

You should update your Java version to Java 6 update 38 or Java 7 update 11.

Update the Java plugin to the latest version.

You can find the latest Java version on the Oracle website.

See Java Platform > Java SE 7U11 and Java 6U38 (Download JRE)