X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox won't display Google maps properly

Posted

I'm using Firefox 18.0.1 which I think is the latest version, on a PC. When Google maps comes up, the zoom bar and all the other buttons and controls on the map itself are way, way too small. So small as to be almost unusable, although they are functional. The map itself also seems to take up more of the screen than it used to.

Firefox works fine on Mapquest (for example). The Internet Explorer (Microsoft) browser works fine on Google maps. It's just the particular combination of Firefox and Google maps that has a problem. Any suggestions?

Chosen solution

hello dmg456, please try to press ctrl + 0 ('zero') while you're on google maps in order to reset the zoom level of the page.

or in case this doesn't fix the issue go through the other common troubleshooting steps described at Websites look wrong or appear differently than they should

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • 4.1.10329.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8891 answers

Chosen Solution

hello dmg456, please try to press ctrl + 0 ('zero') while you're on google maps in order to reset the zoom level of the page.

or in case this doesn't fix the issue go through the other common troubleshooting steps described at Websites look wrong or appear differently than they should

Question owner

Hello 'mad' It worked! Thanks very much for your help. Maybe it's one of those things that you just have to know. I mean, <ctrl> 0, I wouldn't ever have got there on my own. Dave

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96702 answers

You can find the zoom items in the View menu.

  • View > Zoom > Reset (Ctrl+0 (zero); Cmd+0 on Mac)

Press the F10 key or tap the Alt key to bring up the "Menu Bar" temporarily if the menu bar is hidden.

Question owner

Thanks cor-el, what you said about the menu bar definitely helped.

'mad' told me about <ctrl> 0, which worked, and I probably could have gotten there myself if the menu bar had been visible.  But I didn't know there even *was* a menu bar.  I fixed that so it's  up all the time now.

You can certainly find the menu bar option even when it's hidden so I don't really have an excuse. It's just that with the usual software philosophy of top-down search by a series of pulldown menus, you have to recognize the significance of one pathway out of the many you are looking at. Dave